Welcome to the Linux Foundation Forum!

Lab 4.7 and 5.3 PODMAN install and image operatiojns

I am running Ubuntu 20.4. I know that in the past PODMAN ran on Ubuntu 20.4 but I've been trying to install and have tried a number of methods including snap, apt, and wget with zero success, both cutting and pasting from the lab itself and from . I WAS finally able to install using the following command

sudo snap install podman --edge --devmode

But from that point on, I first get 'podman is already installed when I check it, but from that point on any effort to run a podman command fails and a find command finds no evidence of podman.

Has anyone else had this problem? I've had to move on because this seems to be an exercise in futility. Also, I hear that rkt has been mothballed. Did this also happen to Podman after Red Hat bought it as well as CRI-0, and is this why I'm having problems with an Ubuntu install?

Comments

  • chrispokornichrispokorni Posts: 800
    edited December 2020

    Hi @rogerh,

    Thank you for your feedback. According to the podman official documentation, it seems that the installation steps are much simpler today. The snap installation method and usage have not been tested, and are not encouraged either because snap package tend to take up way too much storage space on disk.

    Regards,
    -Chris

  • Hi,

    I'm just pointing to the official documentation, as the link in the previous post is not working:

    https://podman.io/getting-started/installation

    So, basically, as Chris pointed out, it's in the official repos for Ubuntu.

    Regards,
    Luis.

  • saumya043saumya043 Posts: 35

    hello
    i am unable to retrieve release key while downloading podman it is giving me error "gpg:no valid OpenPGP data found"
    i also tried to update apt -get it giving me error of which i have tagged the screen shot

  • saumya043saumya043 Posts: 35

    i am using xubuntu 16.04.

  • ffuentesffuentes Posts: 2

    Hi @saumya043 , according to the official documentation Podman is in the official repo since version 20.10 and from the Kubic project for version 18.04 and newer, so it seems that 16.04 is not supported. I strongly recommend to update your system because it will reach End of life in the next 3 months, on abril of 2021.

  • Hi @ffuentes , that's right!

    Hi @saumya043 , you need to upgrade your Ubuntu system at least to 18.04, better if you upgrade or install 20.10, so you can use the official repos.

    Regards,
    Luis.

  • saumya043saumya043 Posts: 35

    hello @luisviveropena
    i am trying to install linux 20.10 but i dont know why my system is kernel panicking.

  • coopcoop Posts: 653

    More information please. Is this a Virtual machine or a Physical one? If it is a VM what is the host OS etc. Note you can also download a prebuilt VM from https://training.linuxfoundation.org/cm/VIRTUAL_MACHINE_IMAGES using the username and password that appears in your introductory chapter, that will work easily with vmware or virtual box.

    If a physical machine please note at what stage you are failing and how you are trying to install. Just saying it is panicking is not enough info to help.

  • Hi @saumya043 ,

    What exactly is failing? The host, the vm itself? Please provide details about your infrastructure and software you are running.

    Regards,
    Luis.

  • Hi @saumya043,

    The lab exercises were executed on Ubuntu 18.04 LTS running on a GCE VM instance, as introduced in Lab exercise 1.1. I would recommend using a VM for class to be able to isolate it from your daily working environment, and also to be ale to start fast and clean when things go wrong.

    Regards,
    -Chris

Sign In or Register to comment.