Welcome to the Linux Foundation Forum!

Lab 4.3.: CSP blocks display of Horizon dashboard


this is an issue I am facing in Lab 4.3 (Configuring OpenStack for Onap), Step 4, where the lab users are connecting to OpenStack Horizon dashboard via a SOCKS5 proxy.

What works:

  • Established SOCKS5 proxy via Openstack-01 and my Firefox browser on my Linux VM
  • Connecting to the OpenStack Horizon URL via the browser (port 5000)

Where I'm stuck:

  • The output in the browser shows that a Content Security Policy is blocking the display of the Horizon dashboard.
  • Message in the FF developer console:
    "Content Security Policy: The page’s settings blocked the loading of a resource at http: //Horizon-IP:5000/favicon.ico (“default-src”)." // being the Horizon URL as defined in overcloud.rc3

    I understand this is a common problem that can be solved, but I can't find where to manipulate in this specific OpenStack deployment, and since I'm no web developer, I'd appreciate support here.

-> Please help me fix this situation - thanks!

Kind regards


  • SriramRupanagunta


    You may need to set the following in your Firefox browser to enable the content to be displayed.
    (Note: These are mentioned in the ONAP Post-deployment steps - Lab 4.5)

    NOTE: Please check your Firefox browser setting to make sure that Remote Proxy DNS setting is on.
    Type about:config in the address bar
    Select "Accept the risk"
    In the Search enter Proxy
    Enable "network.proxy.socks_remote_dns = true" (Just double click to change the flag)
    Please make sure to undo this change after testing, since this could cause potential security risk!

    NOTE: Please check your Firefox settings to allow mixed contents:
    Type about:config in the address bar
    In the Search enter Mixed
    Click on variable security.mixed_content.block_active_content
    Change the value to False (Just double click to change the flag)


  • gonzalez2020

    Hi Sriram,

    thanks for your response.
    I set the settings as recommended, however I am still getting the error message.
    Is there another setting I should check?
    Thanks in advance.


    Please see the screenshot below

  • gonzalez2020

    Hi Team,

    could you please provide an update?
    I have left this one aside, but I have now progressed to Lab 8, and there Openstack GUI pops up again.

    As stated above, I have set all the parameters as you have recommended. This still doesn't work.
    Your support is appreciated.

    Thanks, kind regards

  • gonzalez2020


    this is solved now.

    It is an incredibly easy solution at the end.
    Apart from setting the variables, the URL to visit is not [Openstack-host IP]:5000, but simply [Openstack-host IP].

    There is many ways to do this wrong, apparently. The error was visible from the screenshots - so apparently nobody really knew it is wrong.
    I wonder how many people stumble across this one.



Upcoming Training