Welcome to the Linux Foundation Forum!

key pair

Hi all, as I am new to Linux and Kubernetes I was following the video about setting AWS instances, and tried to replicate the steps, but probably made a mistake with keys...got the attached error - how can I repair? thanks

Comments

  • Hi @vick76,

    There are several steps that could have gone wrong. Between the .pem key file download, the conversion with putty key generator, or simply just adding the correct .ppk key file to the putty login session, are just a few steps that may not have been completed as expected.

    I would start by attempting the login again, ensuring the .ppk key file is attached to the login profile in putty. If unsuccessful, I would re-generate the .ppk file with putty key generator from the downloaded .pem file. If the new key does not let you log in, then I would create and download a new key-pair and start all over again.

    As a last resort, you can try to login by clicking on the Connect button at the top of the EC2 dashboard, skipping putty altogether.

    Regards,
    -Chris

  • i was merrily using putty for several days with 'master' node and i also suddenly got this same error for no apparent reason. i'm stuck now unfortunately.

  • chrispokorni
    chrispokorni Posts: 1,656

    Hi @username150,

    Unfortunately this randomly happens whit .ppk files on Windows. Luckily you can re-generate the .ppk key with puttygen from the original .pem key file, or simply log in to the EC2 instance from the browser.

    Regards,
    -Chris

Categories

Upcoming Training