Welcome to the Linux Foundation Forum!

Lab 4.6 Install LXD Heads-up

The following command had a couple of issues (cut and paste from the lab failed). Both were related to the number '1' vs the letter 'l'. the font used made the two characters hard to distinguish:

sudo apt install -y acl autoconf dnsmasq-base git golanglibacl1-dev libcap-dev liblxc1 liblxc-dev libtool libudev-dev libuv1-dev makepkg-config rsync

So if you are having 'unable to locate package' errors when trying to use this command, that's why. focus on the packages that can't be found and change out the characters accordingly.

Comments

  • Hi @rogerh,

    I agree that when zoomed out, the two characters are hard to distinguish, but that only impacts users who are typing the command manually. In that situation I recommend zooming in, it will make characters much easier to distinguish.

    However, a copy and then paste of the command ensures that each character is recognized automatically, regardless of the font used.

    Regards,
    -Chris

  • rogerhrogerh Posts: 10

    Hi @chrispokorni ,

    Unfortunately I did that - copied and pasted the command and it failed. That's when I started looking at the syntax more carefully. Anyway it now works.

    Best,

    Roger

  • so finally, which was the right command?

  • (base) [email protected]:~$ sudo apt install -y acl autoconf dnsmasq-base git golanglibacl1-dev libcap-dev liblxc1 liblxc-dev libtool libudev-dev libuv1-dev makepkg-config rsync
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package golanglibacl1-dev
    E: Unable to locate package makepkg-config

  • Installing like this would it all right?
    sudo apt install lxd

  • Hi @lipiss ,

    It seems that LXD is now being managed by 'snap'. Are you using Ubuntu?

    I just did the following:

    [email protected]:~$ sudo snap install lxd
    [sudo] password for luis:
    lxd 4.8 from Canonical✓ installed

    You can take a look to the official LXD documentation:

    https://linuxcontainers.org/lxd/getting-started-cli/#ubuntu

    I hope that helps,
    Luis.

  • coopcoop Posts: 691

    Just curious.
    I have wiped snap off of my Ubuntu systems. (Don't ask..)
    However, if I do apt-get install lxd it wants to install snap and lxd. So far I have not run into any other software that forces me to use snap. So it reverses sudo apt autoremvove --purge snapd gnome-software-plugin-snap
    as I have done on many systems. So it returns snap from the graveyard.

  • Hi @coop ,

    It seems there is a similar debacle about installing Chromium on Ubuntu, because it installs the snap package instead -at least on Ubuntu 20.04, not Ubuntu 18.04.

    Look at this:

    [email protected]:~$ sudo apt install chromium-browser

    [...]

    Preparing to unpack .../chromium-browser_1%3a85.0.4183.83-0ubuntu0.20.04.2_amd64
    .deb ...
    => Installing the chromium snap
    ==> Checking connectivity with the snap store
    ==> Installing the chromium snap
    chromium 87.0.4280.88 from Canonical✓ installed
    => Snap installation complete
    Unpacking chromium-browser (1:85.0.4183.83-0ubuntu0.20.04.2) ...
    Setting up chromium-browser (1:85.0.4183.83-0ubuntu0.20.04.2) ...
    Processing triggers for mime-support (3.64ubuntu1) ...
    Processing triggers for hicolor-icon-theme (0.17-2) ...
    Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
    Processing triggers for desktop-file-utils (0.24-1ubuntu3) ...
    [email protected]:~$

    Regards,
    Luis.

  • coopcoop Posts: 691

    you could install google-chrome-stable instead unless you need chromium I guess. We purge snap from all LF Ubuntu VM's that we make available, because it can double the size of the compressed VM's since it adds GBs of incompressible material; even its cleanup utility (which takes work to find and configure, it is hidden) leaves most of it. But any student can easily add it back in even the need it.

Sign In or Register to comment.