Welcome to the Linux Foundation Forum!

BUG overlayfs

I just started to understand the intricacies of the internal structure of my favorite operating system - Linux.
But I had a problem that I cannot solve for a long time.

Error msg:

======== Card detection to detect SDIO card! ========
[ 1.382561] sdio: host isn't initialization successfully.
[ 1.555398] vendor storage:20160801 ret = 0
[ 3.030025] EXT4-fs (mmcblk1p5): mounted filesystem with ordered data mode. Opts: (null)
[ 3.035553] VFS: Mounted root (ext4 filesystem) readonly on device 179:5.
[ 3.042627] devtmpfs: mounted
[ 3.048086] Freeing unused kernel memory: 1216K
[ 3.287706] EXT4-fs (mmcblk1p6): recovery complete
[ 3.300390] EXT4-fs (mmcblk1p6): mounted filesystem with ordered data mode. Opts: (null)
[ 3.341386] overlayfs: cleanup of 'work/work' failed (-39)
[ 3.346685] overlayfs: failed to create directory /tmp/upper/work/work (errno: 17); mounting read-only
[ 3.381576] failed to power up DHD generic adapter, 1 retry left

I am using kernel version 4.4 (aarch64).
As I understand it, the fact is that the workdir folder is not empty.
I have one very important question:
How can the bug be reproduced?
I tried to load all the memory - it didn't work, turned off the power (unexpected shutdown) and tried different methods, but it did not work. This error appears by itself, I would like to learn how to reproduce it in order to fix it myself in the future.

Thank you in advance.

Sign In or Register to comment.