Welcome to the Linux Foundation Forum!

lab 2.2 course LFS211

while doing lab 2.2 of chapter 2 ,where we have to manually start a service named vsftpd.
while running '/usr/sbin/vsftpd /etc/vsftpd.conf ' its giving me error
"500 00ps : config file not owned by correct user ,or not a file.


  • lee42x
    lee42x Posts: 380

    Hi saumya043,
    Normally the /etc/vsftpd.conf file is included in the package vsftpd and is installed by default. The permission should be set as user= root, group = root and the permissions of 644.
    Which distribution are you using?
    Please confirm if the file /etc/vsftpd.conf exists.

  • yes /etc/vsftpd file exists . i am using ubuntu on vmware fusion .

  • i tried to change permission ....but still not working

  • lee42x
    lee42x Posts: 380

    I see two things:
    First there is a minor typo for the service location it lives in the "sbin" directory so the commad is "/sbin/vsftpd" and second, the # in commands in our book mean "run as root" vs $ "run as regular user"
    so try this:

    sudo /sbin/vsftpd /etc/vsftpd.conf

    Regards Lee

  • tried this also..... but then its does not return anything

  • lee42x
    lee42x Posts: 380

    This is the server for ftp. We can run the background so it does not take up your terminal. Add an "&" after the command to run it in background.

    Test the server with your favourite ftp client. The "ftp" client program is available in the "ftp" package.

    Regards Lee

  • georgi_tsenov
    georgi_tsenov Posts: 1
    edited December 2020


    When you start the service with only:
    # /usr/sbin/vsftpd
    The daemon is spawned and the service is running - you can verify with:
    # ps aux | grep vsftp

    or with telnet:
    # telnet localhost 21
    Trying ::1...
    Connected to localhost.
    Escape character is '^]'.
    220 (vsFTPd 3.0.2)

    or by connecting to the service:
    # ftp localhost
    Trying ::1...
    Connected to localhost (::1).
    220 (vsFTPd 3.0.2)
    Name (localhost:root):

    The /etc/vsftpd/vsftpd.conf argument (/usr/sbin/vsftpd /etc/vsftpd/vsftpd.conf), can be omitted when starting the service (it is read by default).

    Enjoy your Linux experience!

    Best Regards,
    G. Tsenov
    Linux Foundation Certified System Administrator

  • thank you @georgi_tsenov and @lee42x


Upcoming Training