Welcome to the Linux Foundation Forum!

when I run first-network setup shows errors?!

When I run: yes | ./byfn.sh up
It shows errors:
Error: error getting chaincode deployment spec for mycc: error getting chaincode package bytes: failed to calculate dependencies: incomplete package: github.com/hyperledger/fabric/core/chaincode/shim
!!!!!!!!!!!!!!! Chaincode installation on peer0.org1 has failed !!!!!!!!!!!!!!!!
========= ERROR !!! FAILED to execute End-2-End Scenario ===========

ERROR !!!! Test failed
I did run "go get github.com/hyperledger/fabric/core/chaincode/shim"
and tried to ./byfn.sh down and up again, still the same error.


  • Hello,

    Please, check carefully if you followed the setup instruction step by step:
    1. Make sure that both fabric-samples and fabric repos checkouted to corresponding release-1.4 branches.
    2. Run yes | ./byfn.sh generate before spinning the network up.
    3. Check the output of up command. In the very beginning, there should be versions specifications. The correct versions after a step-by-step setup are:


    (1.4.x versions are acceptable)

    If the error still occurs, try to clean network artifacts. If it doesn't help as well, try to run the development environment setup from scratch.

    Best regards,

  • Thanks, fixed.


Upcoming Training