Welcome to the Linux Foundation Forum!

Troubles with ch-16 labs

(sorry if this is a repost of mine, but I cannot find any trace of the original one I did about ch-16 / lab 1)

Yesterday, I was going through all chapter 16 labs, and I struggled to make any of them work.

Each one starts by checking the spawn.status property which happens to be null. I've tried running this in powershell and cmd for Windows 10.

I'm pretty sure this one is trying to verify if executed this command via the package.json > scripts > test, and I did.

I've tried this with jest (22 - 24, 26), as well as the latest tap

Help (again) please,


  • kellv
    kellv Posts: 19

    Ahhh ha! So I think this wound up being a wording issue!

    So testing is all about validation. In a typical experience (at least for me), I've got through a TDD approach, here we're really backfilling tests to gain coverage.

    Now the wording of using the validation file, has been "don't worry about it". I honestly thought you wanted me / users to wire up jest / tap / included assert library to run from npm test. Because of this, I would update the test match to use that validation file (jest as the example). Of course, that doesn't work. What I discovered is that you want us to create the tests.

    For future people that may have this association problem, can you change the wording to help them understand you want them to write their own test file(s)?

  • @kellv thanks for the feedback, to make it clearer I've added "Write tests for the uppercase.js file" in the first lab and "Write tests for the store.js file" in the second and third labs.

  • kellv
    kellv Posts: 19
    edited May 2021

    I'm sorry for the long delay @davidmarkclements ... I failed, felt lost, and got busy with more life stuff. I just wanted to say thank you for updating that.

  • thanks for pointing it out @kellv


Upcoming Training