Welcome to the Linux Foundation Forum!

LS201 Lab 17.3. - Exercise question: Using losetup and parted

while trying out the lab exercise 17.3 I came up with a couple questions that I dont seem to quite understand.

Q1) In the steps 3 and for of the exercise, we are asked to make three partitions (using pared). check partitioned file and then checking the loop devices for that partition with the following commands:

$ sudo parted -s /dev/loop1 unit MB mkpart primary ext4 0 256
$ fdisk -l /dev/loop1
$ ls -l /dev/loop1*

This works wonders when I use the parted command. However, if I partition the imagefile with the fdisk command instead, then the /dev/loop1px files are not created, so I cannot mount these partitions. If then I add a fourth partition but using the 'parted' command then all of the loop devices (loop1p1, loop1p2, loop1p3, loop1p4) are created in the dev directory. I am wondering why does this happen or if there is a way to make it create the loop device after using fdisk.


Q2) Same exercise I also noticed that I can partition either the imagefile directly or the loop device /dev/loopx. Do these two become the same after the losetup -f imagefile?


Q3) I tried to take the exercise a bit further and have the partitioned imagefile not only available at the moment but also after boot time. So I tried to edit the /etc/fstab file with:
/home/myuser/imagefile /home/myuser/mountdir ext4 loop,offset=501760 0 0

This of course, having my second partition start at 256 and having it with the file system ext4 like can be seen below:

$ sudo fdisk -l imagefile
Disk imagefile: 550 MiB, 576716800 bytes, 1126400 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xe79cfb62

Device Boot Start End Sectors Size Id Type
imagefile1 1 500000 500000 244.1M 83 Linux
imagefile2 501760 706559 204800 100M 83 Linux
imagefile3 706560 1126399 419840 205M 83 Linux

Obviously that did not work for me so I am trying to see how to make a loop device partition available after boot time.

Comments

  • coopcoop Posts: 698

    Q1) fdisk and parted are different tools. You can find holy war fights going back probably a decade of fans for either one. fdisk cannot be scripted but has an easier interactive interface. some say it is not as good with the newer GTP systems etc. I don't know but they do have some differences, and people just use the tools that fit the job to be done.

    Q2) once you do losetup it doesn't matter whether you reference the imagefile or the device node, as they are associated with each other exactly.

    Q3) Beats me. I configure mounting squashfs files on loopback all the time in /etc/fstab essentially the way you do without the offset option. I'm assuming you have formatted a filesystem in the partition that starts at that offset. If you haven't of course it would fail as you can only mount known formatted filesystems.

    However, I would never do such a thing (personally) although some folks might find a use for it. If you make even small mistakes with offsets and alignments you wind up with destruction. The only time I've ever partitioned loopback devices is for educational purposes as it is less destructive than telling students to muck with their real disks, and then having them have nervous breakdowns (and blame me) when their system is destroyed. For example we have a Linux device driver course (LFD430) where we not only partition the loopback file, we actually configure them as block devices -- not loopback -- and put filesystems on them and mount them etc, using a device driver we use, essentially a ram disk.

    I hope this helps.

    (We often do unrealistic things while teaching just to elaborate on issues etc. Sometimes students think these are recommended practices :blush: )

Sign In or Register to comment.