Welcome to the Linux Foundation Forum!

Setup VM with Vagrant/Virtualbox [Posted this on the wrong board, couldn't delete it sorry]

Hello there,

I'm trying to setup my study VM with Vagrant and Virtualbox, but i seem to be missing some parts. I'm using the generic/centos7 image from vagrantcloud

After running the ready-for.sh bit, I'm getting the error below. I tried the sudo command the error is mentioning, but that didn't work either.

I couldn't figure out how to add the images from https://training.linuxfoundation.org/cm/VIRTUAL_MACHINE_IMAGES/ to vagrant/virtualbox

`Complete!
WARN: Some packages didn't install: bonnie++
ccache
collectl
gparted
You can perhaps try installing by running:
  ./ready-for.sh --fix-missing --install LFS201
or by:
  sudo yum --skip-broken install bonnie++ ccache collectl gparted
--------------------------------------------------------------------------------
--------------------------------------------------------------------------------
WARN: You may have troubles using this computer for this course unless you can fix the above warnings.
WARN: Ask your instructor on the day of the course if you have more questions.
NOTE: Make sure to follow the instructions above to fix any issues found
[[email protected] ~]$ sudo yum --skip-broken install bonnie++ ccache collectl gparted
Loaded plugins: fastestmirror, product-id, search-disabled-repos, subscription-manager

This system is not registered with an entitlement server. You can use subscription-manager to register.

Loading mirror speeds from cached hostfile
 * base: mirror.sov.uk.goscomb.net
 * extras: mirrors.coreix.net
 * updates: mirrors.gethosted.online
No package bonnie++ available.
No package ccache available.
No package collectl available.
No package gparted available.
Error: Nothing to do`

Please let me know if I can go ahead and start the course, or what else I can do to sort this out :)

Thanks

Comments

  • Hi @dlectronique ,

    Did you try to install the missing packages using "yum install " as root, or using sudo? For example:

    sudo yum install gparted

    Regards,
    Luis.

  • coopcoop Posts: 698

    even easier you can do

    ./ready-for.sh --install --fix-broken LFS201

    This will install everything that can be found. You should have also the EPEL repo installed by ready-for.sh. None of these listed packages matter anyway so don't get stuck.

  • Hello there, thanks for your responses - so basically i've downloaded the image again and managed to get it running in virtualbox.

    Still got the error, but with 4 different packages missing (kernelshark, gnome tweaks, podman and podman-docker). I tried downloading them manually, could only find the last two.

    Ran ready-for.sh again and even though i got a warning i'm still missing 2 packages, it did say my machine was ready.

    When I googled kernelshark and gnome tweaks it doesn't look like they're available anymore. I will get started on the course and hope i don't get in to trouble later on! :smiley:

  • Hi @dlectronique ,

    I don't think you'll miss these packages. So feel free to explore the labs :)

    If you get into any trouble, we are here to assist.

    Regards,
    Luis.

  • coopcoop Posts: 698

    ON RHEL-7 kernelshark is not a package and the script should not be using it. The package is if I remember correctly "trace-gui" and the command "sudo yum install trace-cmd trace-gui" would do it. However, I have no idea why kernelshark is being asked for this course which has no need for it. For RHEL7 the tweak tool has an older name and you have to do "yum install gnome-tweak-tool" or even easier "yum install tweak"

    I'll check with the ready-for.sh maintainer.

  • coopcoop Posts: 698

    you won't miss kernel shark but you will miss gnome-tweak-tool because in their infinite wisdom a lot of essential configuration tools are there and not in "settings", and I could not live without this package. It handles things like extensions and keyboard layouts and desktop appearance etc.

Sign In or Register to comment.