Welcome to the Linux Foundation Forum!

Lab 13.5 - Persistent Network Mounts

In step 4 of the aforementioned lab exercise, when I try to do mount -a, it prompts me for a password, which doesn't seem to be mentioned at all in the lab instructions:

Password for [email protected]//localhost/mainexports:

I tried entering student as the password (as in the credentials in /root/smbfile) but got the following error:

mount error(22): Invalid argument
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Alternatively, I tried entering my root password and leaving the password empty as well but got the same result, and man mount.cifs does not seem to mention about such a password. What should I enter for the password when prompted as above?

Comments

  • lee42xlee42x Posts: 237

    In step 13.4 we created a "smb password" for student. The user root does not have a smb password by default. Please note the passwords used with smb are not the Linux passwords. You must use smbpasswd command to set the password.

    Lee

Sign In or Register to comment.