Welcome to the Linux Foundation Forum!

LFS258 - LAB 3.1 using calico

ahmedzaidiahmedzaidi Posts: 16
edited August 4 in Cloud Engineer Boot Camp

hello TIM.

some issue when i'm trying to apply calico.

[email protected]:~$ kubectl apply -f calico.yaml
Unable to connect to the server: dial tcp 192.168.122.217:6443: connect: no route to host
[email protected]:~$

Comments

  • chrispokornichrispokorni Posts: 635

    Hi @ahmedzaidi,

    This "parent" boot camp forum may not be monitored by instructors and staff and you may not receive the needed support. Please post in the forum associated with the boot camp you registered for.

    From the limited amount of information you provided above, I can see the following:

    1 - The networking between your nodes is not allowing traffic to all ports due to a possible firewall or a missed configuration step on your hypervisor.

    2 - The IP address of your master node (and possibly additional nodes) overlaps with the default Pod IP network used by calico, which is 192.168.0.0/16. This is typical with local hypervisors such as VirtualBox.

    If that is your case, I recommend revisiting your hypervisor configuration and assign IP addresses to your VMs from a subnet different from the default 192.168.0.0/16, otherwise, your Kubernetes cluster does not get configured properly and you run into DNS issues while working on subsequent lab exercises. Also, allowing traffic from all sources, to all ports, and all protocols is recommended. On a local hypervisor, the promiscuous mode should be enabled to allow all traffic.

    Regards,
    -Chris

Sign In or Register to comment.