Welcome to the Linux Foundation Forum!

Ubuntu 18.04 VM Does Not Support Quotas

Hi, I am trying to do Exercise 19.2 - File System Quotas. I am using the Ubuntu 18.04 VM image provided by the Linux Foundation for this course. The uname for this image is: Linux ubuntu 5.7.0

When I try to activate a quota for a file system, I get the error Quota format not supported in kernel. I have followed guidance online which suggested checking for the libraries in /lib/modules/5.7.0/kernel/fs and they are not there. I tried installing linux-image-extra-virtual which succeeded without errors, but the libraries still did not appear and the error message was the same.

I have noticed that there are some quota library files in /lib/modules/4.15.0-109-generic (quota_tree.ko, quota_v1.ko, quota_v2.ko)

If I run quota --version I get Quota utilities version 4.04.

I assumed that the VM image would already be prepared for working with quotas.

Does anyone have any suggestions as to what I can do to get this working ?



  • coop
    coop Posts: 913

    You are using the wrong kernel. The 5.7.0 kernel choice should not be used for non kernel development courses; we use the same VM for about 40 courses. The default choice is the stock kernel from Ubuntu and you should use that. When you reboot, pick advanced options and change if for some reason the default has been set to 5.7.0. (All these VMs are set to use the kernel you used last time, resetting the default so that could be your problem)

    We do not include every option that might be in the stock kernels because compile time would get much longer for constucting the latest kernel.org kernel, plus there are many differences in choices due to the kernel.org kernel being much newer in general,
    and Ubuntu 18.04 is getting older now, there have been probably at least 10 kernel.org releases since then.

  • Thanks for your prompt assistance coop. Problem solved.

  • coop
    coop Posts: 913

    I'm happy when I know the answer. It was clear because you gave the "uname", sometimes we have to ask people for more information before we can help, so you did good :) WIthout that I would have suspected it was kernel version but it can be something else on the system


Upcoming Training