Welcome to the Linux Foundation Forum!

Notes editor: how to use the 'snippet' tool?

GRO 108GRO 108 Posts: 13
edited June 29 in LFS201 Class Forum

Hi, is there a resource for how to use the tools in the Notes editor

I'm trying to work out how to use the snippet tool which I initially assumed was a code formatter but doesn't seem to do anything.

I'm accessing the course using Firefox 77.0.1

Thanks for your help.

Answers

  • luisviveropenaluisviveropena Posts: 548

    Hi,

    Do you refer to the Notes in the course? I tried with Chrome and it works. Can you provide a screenshot with the error you are getting, please?

    Regards,
    Luis.

  • GRO 108GRO 108 Posts: 13

    Hi @luisviveropena,

    Yes it is the Notes in the course. There is no error displayed on the window but there is an error printed to console.

    Error: Failed to create an instance of 'controller:manager/snippets-modal'. Most likely an improperly defined class or an invalid module export. 2 vendor.gulp.bundle.65435eee.js:19:23943
        p https://d36ai2hkxl16us.cloudfront.net/v3/dist/vendor.gulp.bundle.65435eee.js:19
        s https://d36ai2hkxl16us.cloudfront.net/v3/dist/vendor.gulp.bundle.65435eee.js:19
        lookup https://d36ai2hkxl16us.cloudfront.net/v3/dist/vendor.gulp.bundle.65435eee.js:19
        controllerFor https://d36ai2hkxl16us.cloudfront.net/v3/dist/vendor.gulp.bundle.65435eee.js:24
        openModal https://d36ai2hkxl16us.cloudfront.net/v3/dist/main-0d1c234495ecca6c46e5.bundle.js:1
        x https://d36ai2hkxl16us.cloudfront.net/v3/dist/vendor.gulp.bundle.65435eee.js:24
        l https://d36ai2hkxl16us.cloudfront.net/v3/dist/vendor.gulp.bundle.65435eee.js:29
        trigger https://d36ai2hkxl16us.cloudfront.net/v3/dist/vendor.gulp.bundle.65435eee.js:29
        send https://d36ai2hkxl16us.cloudfront.net/v3/dist/vendor.gulp.bundle.65435eee.js:24
        send https://d36ai2hkxl16us.cloudfront.net/v3/dist/vendor.gulp.bundle.65435eee.js:24
        y https://d36ai2hkxl16us.cloudfront.net/v3/dist/vendor.gulp.bundle.65435eee.js:23
        n https://d36ai2hkxl16us.cloudfront.net/v3/dist/vendor.gulp.bundle.65435eee.js:23
        started https://d36ai2hkxl16us.cloudfront.net/v3/dist/main-0d1c234495ecca6c46e5.bundle.js:1
    
  • GRO 108GRO 108 Posts: 13

    I've tried in the following browsers and encountered the same error.

    Chrome: 83.0.4103.116 (Official Build) (64-bit)
    Vivaldi: 2.4.1488.35 (Stable channel) (64-bit)

  • luisviveropenaluisviveropena Posts: 548

    Hi @GRO 108 , does the rest of the functionalities work well? What happens when you click on Notes? What OS are you running?
    I don't see this kind of issue, but I can pass the information and report the issue.

    Regards,
    Luis.

  • GRO 108GRO 108 Posts: 13
    edited June 30

    Hi @luisviveropena

    wrt the snippet tool there is another error output to the console that I'd missed.

    Error: Failed to create an instance of 'controller:manager/snippets-modal'. Most likely an improperly defined class or an invalid module export. 2 vendor.gulp.bundle.65435eee.js:19:23943
    

    Other issues I've encountered. I can't see any errors for these so they may be usability issues.

    • can't delete tables
    • After adding an unordered I can't add text to it (but I can add text and then format as an ul)

    Feature request (where is the best place to make these?): markdown in notes

  • fcioancafcioanca Posts: 477
    edited June 30

    @GRO 108 Thank you for the feedback. I have tested all this functionality on my laptop, and everything works as expected (creating/deleting tables, adding text, bullet points, printing as a pdf, etc), with no errors. Can you please advise what OS are you using?

    Also, for editing notes, please keep in mind you can always do so using the html editor.

    Regards,
    Flavia
    The Linux Foundation Training Team

  • GRO 108GRO 108 Posts: 13

    Hi @fcioanca ,

    Sorry, missed posting the OS in my earlier response :facepalm:

    I'm using macOS Catalina 10.15.5 (19F101).

    Thanks for your help.

  • fcioancafcioanca Posts: 477

    I am using the same OS version and have no issues on Chrome. Did you try clearing your cache first?

  • GRO 108GRO 108 Posts: 13

    Thanks for your help @fcioanca but using Chrome with a cold cache I'm still getting the error.

    Here's a bug report, is there another forum or resource related specifically to the LMS that I should post this to?

    h3. Steps to reproduce

    • As a logged in user
    • navigate to notes
    • add a new note
    • edit note
    • select snippet tool

    h3. Expected result
    Snippets modal

    h3. Actual result
    nothing - the following errors are logged to the console.

    [bugsnag] Ignoring cross-domain or eval script error. See docs: https://tinyurl.com/y94fq5zm
    
    Uncaught Error: Failed to create an instance of 'controller:manager/snippets-modal'. Most likely an improperly defined class or an invalid module export.
        at p (vendor.gulp.bundle.65435eee.js:19)
        at s (vendor.gulp.bundle.65435eee.js:19)
        at r.lookup (vendor.gulp.bundle.65435eee.js:19)
        at r.controllerFor (vendor.gulp.bundle.65435eee.js:24)
        at r.openModal (main-b90108f7d1c421a7233b.bundle.js:1)
        at u.x [as triggerEvent] (vendor.gulp.bundle.65435eee.js:24)
        at l (vendor.gulp.bundle.65435eee.js:29)
        at u.trigger (vendor.gulp.bundle.65435eee.js:29)
        at r.send (vendor.gulp.bundle.65435eee.js:24)
        at r.send (vendor.gulp.bundle.65435eee.js:24)
    
Sign In or Register to comment.