Welcome to the Linux Foundation Forum!

LFS201 - Chapter 13 additional information on log files and authentication

Hi all,

1.- Today I was asked if log files can be delivered to a remote server. For that purpose please do "man rsyslog.conf" ("man 5 rsyslog.conf" will do the same), and search for "Remote machine".

2.- For an advanced way to authenticate against an LDAP server, I can suggest to use 389 Directory Server for testing purposes. You can find it here:

https://directory.fedoraproject.org/

And then you need to setup a service which can work with this LDAP server. Let's think of an email server, such as Zimbra. So you'll need to see if the software supports LDAP. In this case it does:

https://wiki.zimbra.com/wiki/LDAP_Authentication

You'll see it's possible to do with a number of other services as well (we won't do it on the online sessions, as it's not on the course and it consumes lot of time to setup).

Many regards,
Luis.

Comments

  • moulinathmoulinath Posts: 24

    LFS 201 - Chapter 13 - Lab Assignment 13.1 :

    Was trying the swapoff, and getting an error as below :

    [[email protected] ~]$ sudo /sbin/swapoff -a
    [sudo] password for mc1975:
    swapoff: /dev/dm-1: swapoff failed: Cannot allocate memory
    [[email protected] ~]$

    Any feedback ?

  • coopcoop Posts: 437

    that's a rather unusual error. Moving memory out of swap does move it into main memory, so I suppose it is possible So please answer the following questions:

    1) what does cat /proc/swaps show (what are you using for swap)
    2) what does free (or free -m) show (how much memory you have, how much is dedicated to swap and how much used etc.)

    If you are using /dev/dm-1 it sounds perhaps like you are using an lvm device for swap. So plese tell us.

    Also diagnosis will benefit from the following information:

    What distribution and version are you using (for example, ubuntu uses a swap file, other distros use a partition)
    Are you running the stock distribution kernel? There are configuration options which can matter.

    It's pretty hard to debug something when all you know is something went wrong :). But this is not a common error, never seen it in my memory

    This is likely to be a non-reproduceable error, if it is an out of memory problem as it will depend on exactly what was going on.

  • moulinathmoulinath Posts: 24

    [[email protected] ~]$ cat /proc/swaps
    Filename Type Size Used Priority
    /dev/dm-1 partition 2097148 839568 -2

    [[email protected] ~]$ free -m
    total used free shared buff/cache available
    Mem: 790 541 54 5 194 115
    Swap: 2047 819 1228
    [[email protected] ~]$

    I am on CentOS 8

  • luisviveropenaluisviveropena Posts: 544

    Hi @moulinath ,

    It seems the OS is already using swap, and it has very few memory available. So swap can't be disabled until there is enough free memory available.

    Many regards,
    Luis.

  • moulinathmoulinath Posts: 24

    How do I free up enough memory to run the swap disable ? Do I need to drop cache ?

  • luisviveropenaluisviveropena Posts: 544

    @moulinath said:
    How do I free up enough memory to run the swap disable ? Do I need to drop cache ?

    That's one option. Are you running stress-ng already? See with "top" what's using more memory and stop the process, so the OS can free enough memory.

    Regards,
    Luis.

  • moulinathmoulinath Posts: 24

    Looks to be primarily gnome-shell that is consuming about 20%

  • luisviveropenaluisviveropena Posts: 544

    Oh, it seems the total physical memory is too small, 790 mb, right?

    Regards,
    Luis.

  • moulinathmoulinath Posts: 24

    yes

  • moulinathmoulinath Posts: 24

    I am facing a different problem. I was trying to restart the VM in the hope that it will lead to a fresh start. I might have done something wrong , as I am now getting an error message when I am trying to restart

    "The VMware Tools power-on script did not run successfully in this virtual machine. If you have configured a custom power-on script in this virtual machine, make sure that it contains no errors. You can also submit a support request to report this issue."

    Any idea ?

  • luisviveropenaluisviveropena Posts: 544

    Hi @moulinath ,

    I'd say increase memory up to 2GB at least. For the another issue, I'm not sure, as I'm not a VMware user. But it may be related to power-on scripts (and I'm not familiar with that): https://kb.vmware.com/s/article/2010481 .

    Regards,
    Luis.

  • coopcoop Posts: 437

    Your fundamental problem is likely to be not enough memory. If I read your free -m output, you have 790 MB of memory and about 2 GB of swap. This is not healthy. Aside from the swap allocation too large for your memory, your memory allocating is too small to do that much useful if you are running a full desktop. In VMWare you can easily change the amount of memory available with a mouse click or two by going to "Edit Virtual Machine Settings". If you cant' increase the memory to a healthy amount (I would recommend 4 GB but certainly 2 GB as Luis says) then you are using a host machine that is too underpowered to run vmware as a hypervisor.

    Since your swap partition looks like a lvm one (CentOS 8 must have done this during install) resizing it is possible with lvresize and then doing mkswap to the resize partition. But increasing your memory should work without doing this.

    I never recommend having swap larger than RAM (in ancient days there was a time when it said it should be 2xRAM but that was wrong then and now.)

  • lee42xlee42x Posts: 158

    Back to the entry points of this discussion;
    2/ testing with LDAP, a smaller easy to install VM is available from Turnkey.

    https://turnkeylinux.org/openldap

    I use it for LDAP testing all the time. ( CentOS7/8 Ubuntu-20 )

    Lee

Sign In or Register to comment.