Welcome to the Linux Foundation Forum!

Possible Chapter 14 Erata

Just going through Chapter 14, and noticed that under the section I/O Monitoring and Tuning...iostat there seems to be a slight mismatch between the explanatory text and the first screen shot.

The explanatory text states:

After a brief summary of CPU utilization, I/O statistics are given: tps (I/O transactions per second; logical requests can be merged into one actual request), blocks read and written per unit time, where the blocks are generally sectors of 512 bytes; and the total blocks read and written.

However, the matching screenshot displays the last 4 columns of output in kB, rather than blocks. This matches the output I see when I run iostat. Effectively, there doesn't seem to be any difference between this output and that generated when running iostat -k.

This also suggests that this subsequent text on the same page also could do with an update -

A somewhat different display is generated by giving the -k option, which shows results in KB instead of blocks.

Looking through the man page for iostat, this states that the output is in blocks if no parameters are passed to iostat as well - which suggests that behavior has changed over time.

I'm running through this on CentOS 7.



  • coop
    coop Posts: 913


    POSIXLY_CORRECT=1 iostat

    and you will get in blocks. I don't know when the behaviour changed. on RHEL/CentOS 8 the man page does say it will be in KB and not blocks (and 1 KB=2 Blocks) unless you set the above environment variable (to any value). We'll think about how to reword for the future, it is a little more to fix than a typo, and the results are kind of obvious no matter what.


  • dacarab
    dacarab Posts: 8

    Cool, thanks for having a look - tried running it as you suggested and am seeing the output in blocks as you mentioned.


  • moulinath
    moulinath Posts: 24

    LFS 201 - Lab Exercise 14.1 - I am using CentOS 8

    Seems like the distro does not have bonnie++. I tried to do an install as well :

    [mc75@localhost /]$ sudo yum install bonnie++
    Last metadata expiration check: 0:00:57 ago on Wed 01 Jul 2020 05:51:08 PM EDT.
    No match for argument: bonnie++
    Error: Unable to find a match: bonnie++

  • moulinath
    moulinath Posts: 24
    edited July 2020

    LFS 201 - Lab Exercise 14.2 - I am using CentOS 8.

    My fs_mark install failed because of glibc-static not being present. Since I could not locate it, I looked up /etc/yum.repos.d/CentOS-PowerTools.repo and found enabled set as 0.

    name=CentOS-$releasever - PowerTools



    I am not sure if I am to try and update enabled to 1 in the repo itself. The Assignment mentioned that there is a copy of the file with enabled =1 in the Solutions section of the course. I could not find that. Am I missing any step as part of this assignment ?

  • luisviveropena
    luisviveropena Posts: 1,101

    Hi @moulinath ,

    It's easier to install these packages from the EPEL repo. So you install the associated package (for configuring the EPEL repo), and you are ready to search and install them.


  • moulinath
    moulinath Posts: 24

    How do I do that ?

  • coop
    coop Posts: 913

    There's a number of questions here.

    First, to install EPEL, you can look up the epel web page and you will see on it instructions for how to install:


    (You might also consider adding the rpmfusion repos at some point, for other packages but sometimes there are more conflicts)

    As far as turning on PowerTools repo, yes, absolutely turn it on. It will not cause problems

  • moulinath
    moulinath Posts: 24

    I tried sudo yum install https://dl.fedoraproject.org/pub/epel/epel-release-latest-8.noarch.rpm as well as
    sudo yum install epel-release

    In both cases, I am getting :

    CentOS-8 - AppStream 0.0 B/s | 0 B 00:00
    Failed to download metadata for repo 'AppStream'
    Error: Failed to download metadata for repo 'AppStream'

  • coop
    coop Posts: 913

    This error has nothing directly to do with EPEL as it says you were not able to connect to the "AppStream" repo which is CentOS. It's probably easier to directly download the EPEL rpm and then install locally. You can get it from the fedora web site easy enough, or you can get it from https://training.linuxfoundation.org/cm/LFS201 , which you should have encountered in the intro chapter together with the username and password to get in. Download from there and then do:

    sudo rpm -Uvh epel-release-8*.rpm

    (BTW, I would recommend getting used to using "dnf" instead of "yum" on CentOS 8)

    I don't generally like downloading and installing rpms directly from a URL, but it is a nifty capability.

    If you had run ./ready-for.sh --install LFS201 from the same location it should have installed the epel repo for you already!

  • luisviveropena
    luisviveropena Posts: 1,101

    Hi @moulinath ,

    I had a similar issue a couple of weeks ago when trying to install software; in my case it was the source repos that were not responding. In this case, ensure that "baseurl" is uncommented in /etc/yum.repos.d/CentOS-AppStream.repo , as shown in:


    Many regards,


Upcoming Training