Welcome to the Linux Foundation Forum!

LFS201 - Chapter 5 Discussion // Questions // Banter

Options

PACKAGE MANAGEMENT SYSTEMS

Comments

  • moulinath
    moulinath Posts: 24
    Options

    I am working on the Lab 5.1 assignment per the instruction provided. I did install git. am getting a permission denied when I am trying to create a file and adding it to the git project I created after installing git. Any ideas ?

  • coop
    coop Posts: 915
    Options

    Please mention the course number when posting if it is not obvious as there are several in the boot camp :) I gather you are talking about LFS201. I would check where you are working as it sounds like a permission problem. You should be doing everything as a normal user in a directory where you can create files. For example, if your user name in "student", you can do this
    in /home/student; or do something like cd /home/student; mkdir labs; cd labs etc. If you accidentally make a directory while doing sudo, you can do something like sudo chown -R student:student . etc.

    So I can only guess you are working someplace you cannot create files, such as /

  • moulinath
    moulinath Posts: 24
    edited June 2020
    Options

    Sorry - LFS 201 - Chapter 5. Now I am getting the error as below when I am trying to do a git add

    fatal: not a git repository (or any of the parent directories): .git

  • moulinath
    moulinath Posts: 24
    Options

    Was able to resolve and move past it, thanks.

  • luisviveropena
    luisviveropena Posts: 1,163
    Options

    Hi @moulinath , perhaps it would be useful to see a screenshot (for next issue). Also, what user is running the command and also the path.

    Many regards,
    Luis.

  • moulinath
    moulinath Posts: 24
    Options

    LFS 201 - Lab 5.1 - Centos 8.

    I had to uninstall the VM and then install again to fix something else. Now when I am trying to install git, I am getting :

    mc75@localhost /]$ sudo yum install git*
    [sudo] password for mc75:
    CentOS-8 - AppStream 0.0 B/s | 0 B 00:00
    Failed to download metadata for repo 'AppStream'
    Error: Failed to download metadata for repo 'AppStream'

  • moulinath
    moulinath Posts: 24
    Options

    This is now resolved. Thanks.

  • luisviveropena
    luisviveropena Posts: 1,163
    Options

    Hi @moulinath , I'm glad that you were able to solve it. Perhaps it would be good idea to share how you solved it, in case that other student gets the same problem.

    Regards,
    Luis.

  • moulinath
    moulinath Posts: 24
    Options

    I think I might have been running it from the wrong directory

  • luisviveropena
    luisviveropena Posts: 1,163
    Options

    I don't think it was a wrong directory, because you should be able to install from any directory. Perhaps it was a connection issue or a dnf cache issue.

    Many regards,
    Luis.

Categories

Upcoming Training