Welcome to the Linux Foundation Forum!

Trying to install yumex on CentOS-8

Options

I'm trying to install yumex on CentOS-8 as is done in the Chapter 8 demo.

I checked if yumex was already installed using the command
$ which yumex
It was not installed.

I tried to install yumex with yum using:
$ sudo yum install yumex
And got the following error message:
No match for argument: yumex Error: Unable to find a match: yumex

I checked the repos in /etc/yum.repos.d for epel.repo (the one containing yumex in the demo) and it was enabled.

I did a search for yumex as follows:
$ yum list all | grep yumex
and did not find anything. Nothing was found with dnf instead of yum either.

A search using:
$ yum search yumex
which also turned up no matches.

I went to the yumex website here and found a link to the Copr repository containing yumex-dnf here.

I tried to enable the copr repo using:
$ sudo dnf copr enable timlau/yumex-dnf
and got the following error message:
Error: This repository does not have any builds yet so you cannot enable it now.

Tried installing yumex-dnf anyway, using:
$ sudo dnf install yumex-dnf
without any success (no match found).

Followed the link on the timlau/yumex-dnf page for 'more info about enabling copr repos' here

With yum-plugin-copr and dnf-plugins-core installed still wasn't able to find match for yumex or yumex-dnf.

I tried to download the repo file and got as far as finding a git for the repo here. I did not attempt to clone and compile it from the source, yet.

This is as far as I've got so far.

Comments

  • heiko_s
    heiko_s Posts: 99
    Options

    Hi, I was also unable to install yumex. However, when i ran yum list all | grep yumex I got a list of errors not finding the repositories. Need to look into it.

    [heiko@localhost ~]$ yum list all | grep yumex
    Errors during downloading metadata for repository 'AppStream':
    - Curl error (6): Couldn't resolve host name for http://mirrorlist.centos.org/?release=8&arch=x86_64&repo=AppStream&infra=stock [Could not resolve host: mirrorlist.centos.org]
    Error: Failed to download metadata for repo 'AppStream': Cannot prepare internal mirrorlist: Curl error (6): Couldn't resolve host name for http://mirrorlist.centos.org/?release=8&arch=x86_64&repo=AppStream&infra=stock [Could not resolve host: mirrorlist.centos.org]

    But this doesn't effect the epel repo:
    [heiko@localhost ~]$ sudo yum repolist
    repo id repo name
    AppStream CentOS-8 - AppStream
    BaseOS CentOS-8 - Base
    epel Extra Packages for Enterprise Linux 8 - x86_64
    epel-modular Extra Packages for Enterprise Linux Modular 8 - x86_64
    extras CentOS-8 - Extras

    So you see you are not alone. Perhaps it's a Centos 8 thing - haven't tried Centos 7.

  • luisviveropena
    luisviveropena Posts: 1,163
    Options

    Hi all,

    I was checking on this, and it seems yumex hasn't been included on EPEL for CentOS 8 (seems it's not been developed/maintained anymore). But it's available for CentOS 7. We can see it in the today's session if you want.

    There are a couple of useful URLs to review:

    This first one is for asking for a dnf graphical interface:
    https://forums.centos.org/viewtopic.php?t=72039

    A bug opened to enable dnfdragora to EPEL8:
    https://bugzilla.redhat.com/show_bug.cgi?id=1769168

    Many regards,
    Luis.

  • coop
    coop Posts: 915
    Options

    The demo was produced before RHEL 8 came out, so this was not an issue. Otherwise I don't think things have changed. I will look at the demo and see if we need to do a newer more up to date one. thanks for calling this to our attention. (Note yumex is never mentioned anywhere in the course itself :wink: )

  • zsoltsandor
    Options

    Yumex has been deprecated, but dnfdragora has not been ported to EL8. This was a dealbreaker for me too, as much as I love CentOS. Apper on KDE is not the best deal, but the only usable, Discover is not a good option for more granular package search, eg libs. On Gnome, your only option is Gnome Software, and maybe Gnome PackageKit, but I was on KDE, so can't tell.
    (And for KDE, I needed to allow EPEL Playground, and Testing, and CentOS Stream, etc. Not recommended for beginners.)

  • coop
    coop Posts: 915
    Options

    I just put in it in the queue to remove yumex from the course. I was hoping to replace it with dnfdragora, maybe showing on FC-32, but when I installed in on there (dnf install dnfdragora*) the first two times I ran it it not only crashed, it crashed the entire system for reasons unknown, and not worth figuring out. It it doesn't work on Fedora, I would not expect it soon on EL8. So you will have to live (for now) with the not-very thrilling GUI you get by clicking on Applications->System Tools->Software. (Assuming you have the Applications menu, which you may have to get by installing gnome-shell-extension-apps-menu on some brain-dead distributions.)

    All these courses (except LFS101x) are done only from the command line anyway. For some of the demos we did them using GUIs just to augment things, but it was not the skills we were trying to teach for exactly these reasons -- they differ from distro to distro and are less stable than the command line approaches.

    Sorry for the confusion and for those who valiantly tried to get it sorted out. So it goes with LInux :)

  • zsoltsandor
    Options

    I found dnfdragora to be very poor in terms of UX and visual feedback. Yumex was a quite good tool, although nothing comes close to Synaptic and YaST.

  • coop
    coop Posts: 915
    Options

    For some reason Ubuntu has not installed synaptic by default for a long time. They want you to use their software store or whatever they call it, which looks like an app store. Buy you can always do sudo apt install synaptic :)

  • zsoltsandor
    Options

    Anyway, don't try to install yumex-dnf from Fedora COPR (similar to Ubuntu PPAs), it will complain about some Python packages, if I recall that right.

  • heiko_s
    heiko_s Posts: 99
    edited June 2020
    Options

    If you are on a Ubuntu based distro, the best choice for a GUI installer is Synaptic. It's been around for years, shows descriptions, and has even a changelog info. The last option is important - I want to know the changes in package updates before I "upgrade" packages. More often than not a new package can break things. Reading the changelog lets me know if the update is relevant or not. Sometimes I hold back a few days to see what others report on the update.

    Linux Mint has synaptic installed by default. That distro is not a server distro, but has a lot of features to actually support commercial deployments.

    Here is a synaptic screenshot:

Categories

Upcoming Training