Welcome to the Linux Foundation Forum!

lab 2.1 username and passward failed.

I receive the 401 Restricted error. Username/password Authentication Failed. Do the labs need to be updated?

Comments

  • chrispokorni
    chrispokorni Posts: 1,552

    Hi @philmon,

    The user and password in the lab are correct.

    I recommend reading each step carefully. In this case, you may have missed an important note in the same text box with the download command:

    (Note: depending on your software, if you are cutting and pasting the above instructions, the underscores may disappear and be replaced by spaces, so you may have to edit the command line by hand!)

    Regards,
    -Chris

  • fcioanca
    fcioanca Posts: 1,350

    If you used copy/paste from the lab pdf, check and make sure that all characters in the command are there. Copy/paste from pdf is known to remove underscores _, replacing them with spaces - per the note below the command.

  • philmon
    philmon Posts: 4

    I didn't miss it. wget https://training.linuxfoundation.org/cm/LFD259/LFD259_V2020-04-17_SOLUTIONS.tar.bz2\ --username=xxxx --password=xxxxxx. I have removed the username and password in the command. I have manually typed the command copy pasted and added the underscores. password and username match the ones in the labs.

    Resolving training.linuxfoundation.org (training.linuxfoundation.org)... 151.101.193.5, 151.101.1.5, 151.101.65.5, ...
    Connecting to training.linuxfoundation.org (training.linuxfoundation.org)|151.101.193.5|:443... connected.
    HTTP request sent, awaiting response... 401 Restricted

  • fcioanca
    fcioanca Posts: 1,350

    You can always access/download the course resources from Chapter 1, the Course Resources page. We just checked it and it works.

  • philmon
    philmon Posts: 4

    so the newer version is blocked. I can download the older labs without an issue.

  • chrispokorni
    chrispokorni Posts: 1,552

    If you remove the username and password then you will get the restricted access message.

    The backslash \ is not part of the link, it is used here as a separator for a multi-line command.

    Regards,
    -Chris

  • chrispokorni
    chrispokorni Posts: 1,552

    The newer version may be cached in your browser under the wrong URL, with the added backslash \.

    Removing it will allow you to download the latest SOLUTIONS tarball.

  • philmon
    philmon Posts: 4

    Thanks everyone it is working now.

  • mv LFD259_V2021-01-26_SOLUTIONS.tar.xz LFD259.V2021-01-26.SOLUTIONS.tar.xz Problem solved. :)

Categories

Upcoming Training