Welcome to the Linux Foundation Forum!

Lab 2.2 - kubeadm init fail when executing k8sMaster.sh script

When I followed Lab2.2 to execute k8sMaster.sh script, I got below errors, after roughly investigate, it got errors when go to the step:
sudo kubeadm init --kubernetes-version 1.18.1 --pod-network-cidr 192.168.0.0/16

anybody got similar response before?

Comments

  • This issue is resolved, it was caused my network in China, now I changed to use aliyun repository, then it works now, attach my command for your reference:
    sudo kubeadm init --image-repository registry.cn-hangzhou.aliyuncs.com/google_containers --kubernetes-version 1.18.1 --pod-network-cidr 192.168.0.0/16

    if you got the same issue, you need to edit the k8sMaster.sh file and change it as above.

  • Hi @ecyhien,

    Your feedback is much appreciated.

    Regards,
    -Chris

  • Is it LFS258? Because in my course, there is no Lab2.2.

  • Hi @rudysp,

    The previous post is from another course. Thanks for pointing this out, we should do some spring cleaning to avoid any confusion.

    You are fine, there is no 2.2 in LFS258.

    Regards,
    -Chris

  • Hi @rudysp,

    There's no Lab 2.2 in the LFS258 course. This thread should be posted in the forum for Kubernetes for Developers (LFD259).

    Thank you,
    Magda
    The Linux Foundation Training Team

Categories

Upcoming Training