Welcome to the Linux Foundation Forum!

LFS201; Lab 14.2. fs_mark: mount -o remount error

Hello,
I would appreciate any help on the below.

In lab 14.2 we are looking at fs_mark and iostat results.
It is suggested to observe how the results change after remounting the file.

I have run the following command:
sudo mount -o remount,journal_async_commit /tmp

However I am getting this error
mount : /tmp mount point not mounted or bad option
(same happens if I substitute /tmp with /)

The exit status is '32' - mount failure.
I was trying to find any solution on the web to no avail.

I am using Xubuntu; 18.04.1-Ubuntu
The files are ext4 files.

Thank you,
Aga

Comments

  • coop
    coop Posts: 754

    The error message is telling you the "journal_async_commit" option conflicts with the filesystem's current attributes. (You can verify that is the problem by running the command as just "sudo mount -o, remount" to show it is not the filesystem mount point etc. You can see what features your filesystem has by doing "dumpe2fs /dev/sdc2 | grep features" (use whatever actual device /tmp is on, which can find out by doing "df /tmp".

    I must confess that on my current system (RHEL 8) I don't see anything like "data_ordered" in my options that would prevent this from working, but I am far from an expert on ext4 -- this lab was tested and worked on other, older distributions. If I wanted to take the time to figure it out I would create some temporary new filesystems with ext4, specifying options with either mkfs.ext4 or tune2fs and see when I run into trouble, but it is an optional exercise foisted on me by such an expert, so maybe someone else knows the answer? (it's a little advanced for this course.) Thanks for your diligence.

  • luisviveropena
    luisviveropena Posts: 789
    edited April 2020

    Hi Aga,

    I don't have Xubuntu 18.04.1, but I do have Ubuntu 19.10. When doing the testcase with an iso image having an ext4 filesystem, I had the same error message. Can you tell me what do you get when you do 'dmesg', please?

    I get the following at the end:

    [78095.695612] EXT4-fs (loop20): mounted filesystem with ordered data mode. Opts: (null)
    [78233.749679] EXT4-fs (loop20): can't mount with journal_async_commit in data=ordered mode

    And I want to check if we are having the same issue here.

    Regards,
    Luis.

  • coop
    coop Posts: 754

    Luis, you are confirming what I said, you can't have data=ordered with journal_async_commit :)

  • Hehehe, ok Coop, that's good.

    I'll send you an email.

    Regards,
    Luis.

  • agnieszka
    agnieszka Posts: 11

    Thanks guys for your replies.

    After some web search:
    1) It seems that for ext4 'data=ordered' is the default mode [see man ext4]
    2) 'data=ordered' does not work with the journal_async_commit
    https://wiki.archlinux.org/index.php/ext4 states
    "For those with concerns about both data integrity and performance, the journaling can be significantly sped up with the journal_async_commit mount option. Note that it does not work with the balanced default of data=ordered, so this is only recommended when the filesystem is already cautiously using data=journal. "
    Confirmed by:
    https://patchwork.ozlabs.org/project/linux-ext4/patch/[email protected]/

    2) I have changed the data mode to data=journal. Note: this mode needs to be passed to kernel as boot parameter.
    a) to change the data mode permanently, add the following to your /etc/default/grub

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash rootflags=data=journal"
    sudo update-grub
    reboot

    b) to change the data mode temporarily, on your GRUB menu press 'e' and add rootflags=data=journal to the line starting with "Linux"
    c) to check , if the change has applied, run command: "cat /proc/cmdline" and check for rootflags

    For point 2, I have followed the advice under the links:
    https://askubuntu.com/questions/1108320/is-etc-fstab-used-to-remount-drives/1108326
    https://askubuntu.com/questions/19486/how-do-i-add-a-kernel-boot-parameter

    3) The above changes have allowed me to successfully remount / with journal_async-commit option.

    Aga

Categories

Upcoming Training