Welcome to the Linux Foundation Forum!

Lab 4

Options

HI, the packet to install is runc or runC,

i execute apt-get install runC
root@ubuntu-s-1vcpu-1gb-nyc1-01:/sys/fs/cgroup# apt-get install runC
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package runC

which otehr option can I use for isntall packet

Comments

  • etofran810
    Options

    for docker the process not worked

    root@ubuntu-s-1vcpu-1gb-nyc1-01:~# curl -fsSL https://get.docker.com/ | sh

    Executing docker install script, commit: 442e66405c304fa92af8aadaa1d9b31bf4b0ad94

    the rkt is ok

    root@ubuntu-s-1vcpu-1gb-nyc1-01:~# git clone https://github.com/coreos/rkt
    Cloning into 'rkt'...
    remote: Enumerating objects: 4, done.
    remote: Counting objects: 100% (4/4), done.
    remote: Compressing objects: 100% (4/4), done.
    remote: Total 34913 (delta 0), reused 1 (delta 0), pack-reused 34909
    Receiving objects: 100% (34913/34913), 25.48 MiB | 18.02 MiB/s, done.
    Resolving deltas: 100% (21600/21600), done.
    root@ubuntu-s-1vcpu-1gb-nyc1-01:~# cd rkt/
    root@ubuntu-s-1vcpu-1gb-nyc1-01:~/rkt# pwd
    /root/rkt

  • etofran810
    Options

    executed the scripts and not worked

    root@ubuntu-s-1vcpu-1gb-nyc1-01:~/rkt# scripts/install-rkt.sh
    ++ mktemp -d

  • chrispokorni
    chrispokorni Posts: 2,193
    edited March 2020
    Options

    Hi @etofran810,

    Linux environments are case sensitive, so installing runc would require it to be spelled with all lower case runc.

    For Docker and rkt you can always check the official documentation and the installation guides of latest releases:

    https://docs.docker.com/install/linux/docker-ce/ubuntu/

    https://github.com/rkt/rkt/blob/master/Documentation/trying-out-rkt.md#trying-out-rkt

    Regards,
    -Chris

  • rogerh
    rogerh Posts: 10
    Options

    Regarding Lab 4.5 Install RKT, I must be missing something. I tried going through the steps in the lab and got a number of wget-and-other based errors. I went to the RKT site and was able to use the following:

    wget https://github.com/rkt/rkt/releases/download/v1.30.0/rkt-v1.30.0.tar.gz

    With success, but from that point on, the lab instructions in the lab got me nowhere. And then I discovered another installation method:

    $ sudo apt install rkt

    result:

    $ rkt version
    rkt Version: 1.30.0
    appc Version: 0.8.11
    Go Version: go1.13.5
    Go OS/Arch: linux/amd64
    Features: -TPM +SDJOURNAL

    THAT was successful. If the intent of the lab was to install rkt, what were the following commands for? Was there another lesson to be learned besides a simple install?

    $ gpg —recv-key 18AD5014C99EF7E3BA5F6CE950BDD3E0FC8A365E
    $ gpg --verify rkt_1.30.0-1_amd64.deb.asc

    I won't go into wget.

    The gpg -verify... command failed with

    gpg: can't open 'rkt_1.30.0-1_amd64.deb.asc': No such file or directory
    gpg: verify signatures failed: No such file or directory

  • chrispokorni
    Options

    Hi @rogerh,

    It seems that some of the rkt secure install artifacts have been removed from the official repository, and cause a few steps to no longer work as expected. But as you discovered yourself, it can still be installed and used as a runtime for testing purposes.

    Regards,
    -Chris

  • saumya043
    Options

    hello everyone
    i am not able to install docker with second method in lab 4.3.
    whenever i am running 'sudo apt install -y apt-transport-https ca-certificates curlgnupg-agent software-properties-common'
    its showing me error package not found

  • chrispokorni
    chrispokorni Posts: 2,193
    Options

    Hi @saumya043,

    You have a typo in your command. There should be a space between curl and gnupg

    Regards,
    -Chris

Categories

Upcoming Training