Welcome to the new Linux Foundation Forum!

UDP unconnect doesn't work on kernel V5

Hello,

I have an application that has been working for a very long time, under various distributions, under the kernel v2, v3 and v4 and I never had problem. Now I'm trying to make it work on Ubuntu with a kernel V5 and I have a problem. It is base on UDP sockets and there is a discovery mechanism that uses broadcast packets. The way it works, a client send a broadcast UPD packet and all servers answer to this broadcast. After that, the client get information from each servers by sending directed UPD packet to every servers that had responded to the broadcast. On the server side, when an UDP packet is received, I call connect with the address of the client so I don't have to follow the client address and port any further in the code. Once the answer has been sent, I "unconnect" the socket by calling connect with an AF_UNSPEC sin_family.

This was working fine but not with a V5 kernel. After I unconnect, it seems that the server doesn't receive directed communications. It receives broadcast UPD fine but not the one that are specifically addressed the it.

Just in case other factors would be the cause of the problem (firewall, etc...), I made a small test code and see the same thing. If I don't use the connect/unconnect, it works fine. But not with the connect/unconnect.

I don't understand because this is a documented way of working with UDP sockets. I googled a lot and I haven't found anything that would suggest the it doesn't work with Linux kernel V5.x.

Does somebody have any idea about this problem?

Thank you.

Frank

Comments

  • I tried with the last of kernel 4 (4.20.17) and it's working fine. Then I tried with 5.0.1 and it doesn't work. So the problem really seems to comes from the kernel 5.

Sign In or Register to comment.