Welcome to the new Linux Foundation Forum!

Trouble with Lab 3.2 (Examining System V IPC Activity)

wings 2wings 2 Posts: 12
edited January 3 in LFS201 Class Forum

Hey everyone,

I had some issues working with Lab 3.2 as the output of ipcs was totally blank. This was on a standard Ubuntu 18.04 64-bit server.

I think the issue is that a basic Ubuntu Server installation no longer really uses System V IPC, so you won't see anything... I resolved it by using a Ubuntu 18.04 Desktop VM for that lab instead, which I luckily had lying around... and bam, some stuff showed up.

Hopefully this helps somebody :)

Comments

  • Hi wings2,

    Did you test it with Ubuntu Server 18.04.3 LTS? I ask so I can do a testcase.

    Regards,
    Luis.

  • coopcoop Posts: 341

    sudo ipcs

    on Ubuntu 18.04 (at least) this requires root privilege apparently, while on other distros such as RHEL it does not. Something you should always check as distros have different policies about what normal users can see.

  • wings 2wings 2 Posts: 12
    edited January 9

    Hi Luis,

    Yes, that is exactly what I tested on.

    [email protected]:~$ uname -a && lsb_release -a
    Linux lfcs-ubuntu-srv 4.15.0-74-generic #84-Ubuntu SMP Thu Dec 19 08:06:28 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
    No LSB modules are available.
    Distributor ID: Ubuntu
    Description:    Ubuntu 18.04.3 LTS
    Release:    18.04
    Codename:   bionic
    [email protected]:~$ sudo ipcs
    
    ------ Message Queues --------
    key        msqid      owner      perms      used-bytes   messages
    
    ------ Shared Memory Segments --------
    key        shmid      owner      perms      bytes      nattch     status
    
    ------ Semaphore Arrays --------
    key        semid      owner      perms      nsems
    
    [email protected]:~$
    

    Oops, I should probably clarify - I didn't exactly mean "totally blank" as there is output, it's just that each section is empty.

  • Hi wings 2,

    Ok, thanks. I'll try it.

    Regards,
    Luis.

  • Hi,

    I did a testcase on Ubuntu Server 18.04.3 LTS and you are right, it doesn't show anything when running 'ipcs'. However, Ubuntu Desktop versions works well.

    Regards,
    Luis.

  • coopcoop Posts: 341

    the more interestinq question to me is "why" and secondarily "how" is it limited. Given variations on different distributions and versions I don't think it is worth getting twisted on how to fix since it is almost always true sudo gets the info, and only the system admin would tend to care about this info anyway. There are other ways to see what shared resources a user's process is consuming, such as lookin in the /proc/[pid] director AFAIK

  • wings 2wings 2 Posts: 12

    @coop - I agree, but even using sudo no useful information is printed. Running it as root was one of the first things I tried :smile:

  • coopcoop Posts: 341

    I don't disbelieve you got the null result with ubuntu server, I was saying unless someone cares it is not worth figuring out. I don't know if it is a bug or a feature. If you do care, debug it. Try something like:

    sudo su
    strace ipcs

    and see where it goes wrong. Is it a permission problem? Is it missing files/packages? Is there any reason to disable this on server vs workstation? My guess as to the last question is "no", noone cares. It is unlikely someone will load up and saturate a server with System V IPC.

    I don't have a ubuntu-server installation and I'm not in the mood to build one just to check out this fringe issue. I.ve seen these kinds of weirdnesses on ubuntu before and they come and go with each new release, they seem more accidental than intentional.

    And as I said there are so many distros, we don't try to cover all quirks, as the trees would get lost in the forest

  • KonstantinAKonstantinA Posts: 7
    edited March 29

    On a Ubuntu 18.04.4 LTS laptop of mine, "ipcs" works. Not on my fedora 31 PC though...

  • Hi @KonstantinA,

    Did you run 'ipcs' on Fedora 31 as normal user, root, or using 'sudo'?

    Thanks,
    Luis.

  • False alarm. It works with and without sudo, on Fedora.

  • coopcoop Posts: 341

    not exactly a false alarm. It was mentioned in the original thread that it has this different behaviour on ubuntu server and not on ubuntu desktop. So it is a linux distribution question. I have no idea why Ubuntu Server does it that way :)

  • Hi KonstantinA,

    Ok, good to know. Thanks for the update.

    Regards,
    Luis.

Sign In or Register to comment.