Welcome to the new Linux Foundation Forum!

Possible error in ingress.rule.yaml and work around

I have just completed the LFS258 course (https://www.youracclaim.com/badges/1d082498-dbb4-4930-ac56-896e919c55f8) and found it to be challenging and fun. I used GCP with free credits and built the cluster using GCE instances running Ubuntu 16.04, everything worked perfectly (just make sure you delete all firewall rules if you are doing it this way).

I only found one issue the whole time. In the lab exercise "Advanced Service Exposure" (part of lesson 10), I could not create the ingress using the supplied ingress.rule.yaml file. The way I fixed this was to change apiVersion from "networking.k8s.io/v1" to "networking.k8s.io/v1beta1" and it worked.

Just thought I'd share this in case anyone else has the same issue.

Comments

  • Thank you for your feedback. You are correct, a minor fix is needed for the Ingress resource to be created, by replacing "v1" with "v1beta1".

    Regards,
    -Chris

Sign In or Register to comment.