Welcome to the Linux Foundation Forum!

Unable to update BatchSize

Options
VladislavIvanov
VladislavIvanov Posts: 1
edited December 2019 in LFS272 Class Forum

I want to update the orderer configuration such as BatchSize. I have scaled our network(./startFiles) from single to multi-organization. But when I am updating orderer configuration then I am getting error as:

Error: got unexpected status: BAD_REQUEST -- error applying config update to existing channel 'allarewelcome': error authorizing update: error validating DeltaSet: policy for [Value] /Channel/Orderer/BatchSize not satisfied: implicit policy evaluation failed - 0 sub-policies were satisfied, but this policy requires 1 of the 'Admins' sub-policies to be satisfied

I have signed the envelope.pb file with admin from orderer org as it is described:
Change an ordering configuration - Majority of admins from orderer orgs (in my case just one admin)
In addition, I have tried to sign with all admins - orderer, org1 and org2, but the output is the same error as above.

Please give me an advice how to proceed with this issue?

Categories

Upcoming Training