Welcome to the Linux Foundation Forum!

Lab 13 web-ui connection to the rest-backend service not working

@spgreenberg still on lab 13, I ran into another issue. I am not able to verify the web-ui connection to the rest-backend service. I created the rest-back-end service with the credentials of my roster app. However when I bind the web-ui to that service and launch the route to the web UI I get the follow error when I hit the view people button: Please connect your app to the rest data service
Any thoughts on what I am missing?


  • Can you post the output of cf env web-ui? Also make sure you have restarted the web-ui after you bound the service instance.

  • This is the output, I'm not seeing what its missing:

    "user-provided": [
    "binding_name": null,
    "credentials": {
    "URL": "https://roster-shy-badger.cfapps.io"
    "instance_name": "rest-backend",
    "label": "user-provided",
    "name": "rest-backend",
    "syslog_drain_url": "",
    "tags": [],
    "volume_mounts": []

    "application_id": "2bef69b6-bc63-41f4-870b-e7f50b171c1b",
    "application_name": "web-ui",
    "application_uris": [
    "application_version": "830b1c1d-020f-4571-94f2-969410cf712e",
    "cf_api": "https://api.run.pivotal.io",
    "limits": {
    "disk": 1024,
    "fds": 16384,
    "mem": 128
    "name": "web-ui",
    "organization_id": "f2d1c7a9-6a58-4daa-9b30-cb8d3ad68691",
    "organization_name": "mtomlinson-org",
    "process_id": "2bef69b6-bc63-41f4-870b-e7f50b171c1b",
    "process_type": "web",
    "space_id": "83fd6ce4-c509-4769-b3f5-267bf78ea886",
    "space_name": "development",
    "uris": [
    "users": null,
    "version": "830b1c1d-020f-4571-94f2-969410cf712e"

    No user-defined env variables have been set

    No running env variables have been set

    No staging env variables have been set

  • the parameter of the user provided service is case sensitive. the name needs to be url and you should also drop the https:// as the value should just be the route of the rest data service. Make those updates, restart the web-ui and it should work.

  • @spgreenberg , that was the issue. Thanks for your help.

  • Excellent! Happy to help.


Upcoming Training