Welcome to the new Linux Foundation Forum!

16.1 LAB HAProxy not starting

I am following Lab 16.1 to install HAProxy for load balancing but HAProxy is not starting getting below error.
`
sudo systemctl status haproxy.service
● haproxy.service - HAProxy Load Balancer
Loaded: loaded (/lib/systemd/system/haproxy.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Tue 2019-10-08 05:30:34 UTC; 10s ago
Docs: man:haproxy(1)
file:/usr/share/doc/haproxy/configuration.txt.gz
Process: 3398 ExecStart=/usr/sbin/haproxy -Ws -f $CONFIG -p $PIDFILE $EXTRAOPTS (code=exited, status=1/FAILURE)
Process: 3389 ExecStartPre=/usr/sbin/haproxy -f $CONFIG -c -q $EXTRAOPTS (code=exited, status=0/SUCCESS)
Main PID: 3398 (code=exited, status=1/FAILURE)

Oct 08 05:30:34 ip-47-228-8-69 systemd[1]: haproxy.service: Service hold-off time over, scheduling restart.
Oct 08 05:30:34 ip-47-228-8-69 systemd[1]: haproxy.service: Scheduled restart job, restart counter is at 5.
Oct 08 05:30:34 ip-47-228-8-69 systemd[1]: Stopped HAProxy Load Balancer.
Oct 08 05:30:34 ip-47-228-8-69 systemd[1]: haproxy.service: Start request repeated too quickly.
Oct 08 05:30:34 ip-47-228-8-69 systemd[1]: haproxy.service: Failed with result 'exit-code'.
Oct 08 05:30:34 ip-47-228-8-69 systemd[1]: Failed to start HAProxy Load Balancer.
`

Comments

  • chrispokornichrispokorni Posts: 307

    Hi @ssubramanian1,
    I experienced similar errors when I started HAproxy based on the configuration presented in the PDF lab exercise alone. When I used the haproxy.cfg file available in the Solutions package I was able to successfully start it.
    Did you use the default haproxy.cfg config file?

    Regards,
    -Chris

  • I tried with solution cfg file now HAProxy does not start throws below error

    `[email protected]:~$ sudo systemctl restart haproxy.service
    Job for haproxy.service failed because the control process exited with error code.
    See "systemctl status haproxy.service" and "journalctl -xe" for details.
    [email protected]:~$ sudo systemctl status haproxy.service
    ● haproxy.service - HAProxy Load Balancer
    Loaded: loaded (/lib/systemd/system/haproxy.service; enabled; vendor preset: enabled)
    Active: failed (Result: exit-code) since Fri 2019-10-11 04:10:32 UTC; 33s ago
    Docs: man:haproxy(1)
    file:/usr/share/doc/haproxy/configuration.txt.gz
    Process: 23785 ExecStart=/usr/sbin/haproxy -Ws -f $CONFIG -p $PIDFILE $EXTRAOPTS (code=exited, status=1/FAILURE)
    Process: 23776 ExecStartPre=/usr/sbin/haproxy -f $CONFIG -c -q $EXTRAOPTS (code=exited, status=0/SUCCESS)
    Main PID: 23785 (code=exited, status=1/FAILURE)

    Oct 11 04:10:31 ip-xx-xxx-8-xx systemd[1]: haproxy.service: Main process exited, code=exited, status=1/FAILURE
    Oct 11 04:10:31 ip-xx-xxx-8-xx systemd[1]: haproxy.service: Failed with result 'exit-code'.
    Oct 11 04:10:31 ip-xx-xxx-8-xx systemd[1]: Failed to start HAProxy Load Balancer.
    Oct 11 04:10:32 ip-xx-xxx-8-xx systemd[1]: haproxy.service: Service hold-off time over, scheduling restart.
    Oct 11 04:10:32 ip-xx-xxx-8-xx systemd[1]: haproxy.service: Scheduled restart job, restart counter is at 5.
    Oct 11 04:10:32 ip-xx-xxx-8-xx systemd[1]: Stopped HAProxy Load Balancer.
    Oct 11 04:10:32 ip-xx-xxx-8-xx systemd[1]: haproxy.service: Start request repeated too quickly.
    Oct 11 04:10:32 ip-xx-xxx-8-xx systemd[1]: haproxy.service: Failed with result 'exit-code'.
    Oct 11 04:10:32 ip-xx-xxx-8-xx systemd[1]: Failed to start HAProxy Load Balancer.`

  • How did you provision your nodes? Are they local or cloud?
    Are all the port numbers in the haproxy.cfg file available for HAproxy to use and accessible (not blocked by a firewall) on your proxy node?
    In the haproxy.cfg, did you edit the master server name and master IP with your own? The file shows defaults:

    backend k8sServers
       balance roundrobin
       server master1  10.128.0.24:6443 check
       ...
    

    Yours should be different (name and IP here are just an example):

    backend k8sServers
       balance roundrobin
       server my-k8s-master-1  10.138.4.15:6443 check
       ...
    

    Regards,
    -Chris

  • jzimnowojzimnowo Posts: 9

    Hi @chrispokorni
    I also have an issue while starting haproxy on my master node.
    After inspecting journalct, I learnt that haproxy is not able to bind stocket:
    Starting frontend proxynode: cannot bind socket [0.0.0.0:6443]

    It makes sense, because kube-apiserver Pod is bound to hostIP 10.164.0.7 and port 6443.

    I am wondering if haproxy should bind to a specific IP (e.g. Virtual IP) ?

    Any clue?

  • chrispokornichrispokorni Posts: 307
    edited October 24

    Hi @jzimnowo,

    The HAproxy is not supposed to run on any of the master nodes. It is running on a separate/dedicated host.
    Read the exercises carefully as they describe the additional resources you need.

    Regards,
    -Chris

  • jzimnowojzimnowo Posts: 9

    Hi @chrispokorni
    Aha, it works now! Thanks

  • Hi @jzimnowo

    have you configure it on other infra node or master nodes.

    Regards,
    DK

  • Hi,

    I am trying to install and configure the HAPROXY on separate ec2 instance on AWS. I opened the port on security group, disable the firewall, enable the port forwarding and exactly followed the same steps as in pdf but still getting the error.

    Dec 12 11:35:27 ip-172-25-4-23 haproxy[26931]: Proxy k8servers started.
    Dec 12 11:35:28 ip-172-25-4-23 haproxy[26946]: [ALERT] 345/113528 (26946) : Starting frontend haproxynode: cannot bind socket [0.0.0.0:80]
    Dec 12 11:35:28 ip-172-25-4-23 haproxy[26946]: Proxy k8servers started.
    Dec 12 11:35:28 ip-172-25-4-23 haproxy[26946]: Proxy k8servers started.
    Dec 12 11:35:28 ip-172-25-4-23 haproxy[26970]: [ALERT] 345/113528 (26970) : Starting frontend haproxynode: cannot bind socket [0.0.0.0:80]
    Dec 12 11:35:28 ip-172-25-4-23 haproxy[26970]: Proxy k8servers started.
    Dec 12 11:35:28 ip-172-25-4-23 haproxy[26970]: Proxy k8servers started.
    Dec 12 11:35:28 ip-172-25-4-23 haproxy[26988]: [ALERT] 345/113528 (26988) : Starting frontend haproxynode: cannot bind socket [0.0.0.0:80]
    Dec 12 11:35:28 ip-172-25-4-23 haproxy[26988]: Proxy k8servers started.

    Let me know if any one have the solution ?

  • Apache may be running on port 80 already. Stop it and/or remove it and try the haproxy again.

    Regards,
    -Chris

Sign In or Register to comment.