Welcome to the new Linux Foundation Forum!

Lab 7.2 Traefik image tag 1.7 needs to be specified

I think version 2 made changes that break the way the lab is setup. Without specifying the tag, I get the following error

$ kubectl logs -n kube-system traefik-ingress-controller-ghn8w --follow
2019/10/04 01:24:38 command traefik error: failed to decode configuration from flags: field not found, node: kubernetes

The solution appears rather simple.

# . . . . .
      hostNetwork: True
      containers:
      - image: traefik:1.7 # Add the 1.7 tag here
        name: traefik-ingress-lb
        ports:
# . . . . .

If you have a better solution feel free to share, but this one worked for me.

Comments

  • chrispokornichrispokorni Posts: 309

    Hi @jdnovick,
    You are correct, due to the latest v.2 released about 1 week ago, we now have to tag the traefik image in the yaml config file.
    Thank you for posting the issue. The exercise will be updated in a future course update release.

    Regards,
    -Chris

  • It worked for me, thanks

Sign In or Register to comment.