Welcome to the new Linux Foundation Forum!

KVM and tigevnc socket issue

Hi,

I have an issue with getting a KVM template built where norally there is no problem:

OS = RHEL 7.5
VNC = TigerVNC

So, I only ever have a minimal install, so only have access to the command line. The following command I enter works everytime with Centos7.5 and TigerVNC:

/usr/share/virt-manager/virt-install --name=template-1a --memory=16384 --vcpus=4 --cdrom=/tmp/rhel-server-7.5-x86_64-dvd.iso --disk path=/home/kvm/disk.qcow2,size=40,bus=virtio --network bridge=virbr0 --os-variant=rhel7.5 --graphics vnc,listen=0.0.0.0 --noautoconsole

The end section of this KVM Template build command tells the system to look for VNC and so the VNC Server should not be required (It was never installed on Centos and that worked.
So, I then edit my firewall rules to allow TCP in the zone public, to ports 5900-6100. When completing the following command I get the below results:

[[email protected] ~]# firewall-cmd --zone=public --permanent --list-ports
5900-6100/tcp

So, I open up my tigervnc viewer, attempt a connection to :5901

And I get the followinf werror returned:

unable to connect to socket: Connection refused (10061)

So, I disable the firewall completely using system firewalld stop and try again. Same result.

I am pulling my hair out over this as I cannot get tigervnc to connect so I can complete the KVM build....

Any ideas anyone please?

Sign In or Register to comment.