Welcome to the Linux Foundation Forum!

Lab 8 - Error: channel create configuration tx file not found open. no no such file or directory


Hi, I struggle really hard in Lab 8 with this error message. It appears once I try to create a new channel (either AllAreWelcomeTwo or OrgTwoChannel). I try to execute the creat channel command both from CLI, or the individual peer containers. The same error message appers.
I also tried to run the teardown.sh script and then re-run bootstrap.sh script, before jumping to chapter 8 trying again. Same error message appears. Obviously I set the three environment variables mentioned in the tutorial as described, based on which container I am inside.
And yes, the artifact (for instance allarewelcometwo.tx is inside the config file within the fabric-samples folder). What could be wrong here? I am on Ubuntu 18.04

Here are my commands:

../bin/configtxgen -profile AllAreWelcomeTwo -outputCreateChannelTx ./config/AllAreWelcomeTwo.tx -channelID allarewelcometwo

I then check the config file, and the artifact is indeed created.

Then I log into the CLI container or peer0 org or peer0org2...I tried them all and changed export commands below accordingly...:

docker exec -it cli bash


export CORE_PEER_MSPCONFIGPATH=/opt/gopath/src/github.com/hyperledger/fabric/peer/crypto/peerOrganizations/org2.example.com/users/Admin@org2.example.com/msp

export CORE_PEER_ADDRESS=peer0.org2.example.com:7051

peer channel create -o orderer.example.com:7050 -f ./config/AllAreWelcomeTwo.tx -c allarewelcome

2019-07-21 14:53:56.921 UTC [channelCmd] InitCmdFactory -> INFO 001 Endorser and orderer connections initialized
Error: channel create configuration tx file not found open ./config/AllAreWelcomeTwo.tx: no such file or directory

Really need help on this one guys, been testing different options now for 5 hours without success...


  • Niklaskkkk
    Niklaskkkk Posts: 113

    To proceed from this error I had to edit in the following into the volumes section of CLI in docker-compose.yml as this line originally was not there when I downloaded the course files.

    • ./config:/opt/gopath/src/github.com/hyperledger/fabric/peer/config

    Is there a specific reason this is not stated in the course documentation? Or did I do something wrong? Since I spent so much time on trying different solutions...

  • Niklaskkkk
    Niklaskkkk Posts: 113

    This thread can be closed. The answer is in Lab 5 where you add the correct volumes for the CLI container.


Upcoming Training