Welcome to the Linux Foundation Forum!

Lab 1 Error: curl: (1) Protocol "​https" not supported or disabled in libcurl

In Lab 1:

When i try to execute the following command it is giving the error

command: curl -fsSL ​https://download.docker.com/linux/ubuntu/gpg​ | sudo apt-key add -

Error: Error: curl: (1) Protocol "​https" not supported or disabled in libcurl

could you please let me know the reason, i am using Oracle virtual box. I wasted lot of time in web but did not get the correct option


  • kmyatt
    kmyatt Posts: 39

    The command you entered above is correct, so you aren't running it wrong. It might be a problem with the installation of curl or another dependency. I recommend you uninstall and reinstall curl, and afterward any other dependency you previously installed. Then it should work. Best of luck

  • maniankara
    maniankara Posts: 11

    @kmyatt and @Amarnath.Aitha I too faced the same problem with AWS ubuntu 18.04. I had to use wget (wget -O- ) instead :neutral:

  • kmyatt
    kmyatt Posts: 39

    @Amarnath.Aitha @maniankara

    Hmmm That's odd. Docker should support that download method using curl. The official documentation even recommends using curl.

    It's most likely an issue with ssl... go ahead and uninstall curl, then run

    sudo apt install libssl-dev
    sudo apt install curl

    That should fix it.

  • garycris
    garycris Posts: 13

    I'm getting this same error and have not been able to get around it. I've spent hours trying to troubleshoot it but nothing works. I've tried different installations of Ubuntu 16 and 18 and continue to have this same problem. Suggestion provided above did not solve. Please let me know if someone has a suggestion. Finding it difficult to move past the initial setup.

  • garycris
    garycris Posts: 13

    used wget as mentioned above to get past this step.

  • I am facing the same problem. Let me know how wget can be used here instead. Tried several ways but not working

  • Nevermind. I resolved this using instruction provided in below link. Worked for me. Issue with https


Upcoming Training