Welcome to the new Linux Foundation Forum!

LFS242 - Cloud Native Logging with Fluentd

Hello,

LFS242 - Cloud Native Logging with Fluentd is now live!

One great way to interact with your peers taking this course is using the Class Forum:

  • Discuss concepts, tools, and technologies presented in this course, or related to the topics discussed in the course material.
  • Ask questions about the course content.
  • Share resources and ideas related to Fluentd.

When starting a thread, be as specific as you can, both in the title and the body of the thread, identifying the chapter and page you are referring to.

We hope you have a great learning experience!

Flavia
The Linux Foundation Training Team

Comments

  • Nice to see this Forum, I have a problem when I run the docker command for Fluentd.
    [email protected]:~$ docker run -p 24220:24220 -p 24224:24224 -v $HOME/fluent:/fluentd/etc -e FLUENTD_CONF=docker.conf fluent/fluentd:stable
    Unable to find image 'fluent/fluentd:stable' locally
    stable: Pulling from fluent/fluentd
    4fe2ade4980c: Already exists
    2958cef2c4a1: Already exists
    f258dfc84aaf: Already exists
    4fb5eec58a23: Waiting

    the last image keeps waiting... and unable to proceed with the lab.

  • Hello Sudeep, can you try to redo the pull?

    [email protected]:~$ docker image rm 9406ff63f205
    
    Untagged: fluent/fluentd:stable
    Untagged: fluent/[email protected]:7eece00d1bc784ac1e9722b2580911cd3ead5afd740dad6594be945b3b1dd884
    Deleted: sha256:9406ff63f205887cdce5dafb21c1d5df261b308d8116accfd2abdd75660875ca
    Deleted: sha256:1b443e7552f30896c841653799b535f106b238e3d6ef2522c1d434136aa1084f
    Deleted: sha256:adc786ed03122600c576ac8eceacaff396f8faeec01349ff106fa0b26830fbb5
    Deleted: sha256:603d6245ad193385838915e7c79aba210ff57e06820c3a8dda7f8e15fe3b2e02
    Deleted: sha256:2f6c6fe229098767973fad8027244bc58e90ec043be79da99a3ab9aae36de01a
    Deleted: sha256:e1bac6bc75a4f27da6a4e1e7b1ef52c77826939a5f14ffdbdd40a238026862ad
    Deleted: sha256:22dac6221e003ec8b8603b00dad87897ad95a9e6aa7d8414cc441ba7fed428aa
    Deleted: sha256:df64d3292fd6194b7865d7326af5255db6d81e9df29f48adde61a918fbd8c332
    
    [email protected]:~$ docker pull fluent/fluentd:stable
    
    stable: Pulling from fluent/fluentd
    4fe2ade4980c: Pull complete 
    2958cef2c4a1: Pull complete 
    f258dfc84aaf: Pull complete .
    4fb5eec58a23: Pull complete 
    e26ea6ff4a8b: Pull complete 
    9446f1fdd28a: Pull complete 
    cc961e53b132: Pull complete 
    Digest: sha256:7eece00d1bc784ac1e9722b2580911cd3ead5afd740dad6594be945b3b1dd884
    Status: Downloaded newer image for fluent/fluentd:stable
    
    [email protected]:~$ 
    

    The command should pull the image directly the Fluent public repo on Dockerhub: https://hub.docker.com/r/fluent/fluentd

    I've performed a pull on my own local VM and have been able to successfully do so.

    If the stable tag is not functional, you may also try to use latest or one of the other v1.x images for that lab.

  • Thanks Christian, Actually it worked next time I tried today in my office LAN (earlier I was trying in my home LAN).
    I didnt need to remove the fluentd image and it just worked on its own this time.
    But thanks for the tip. :smile:
    Sudeep

Sign In or Register to comment.