Welcome to the new Linux Foundation Forum!

Problem installing K8s Master on GCP (exercise 2.2)

debashishdebashish Posts: 5
edited May 16 in LFD259 Class Forum

Hi,

I ran into problem with the installation itself in exercise 2.2, am following the code in LFD259 V2019-03-11 SOLUTIONS. When I run the KbsMaster.sh, kubectl was not installed. Following is the output I got. How do I get past this? It seems the issue is regarding incompatible CNI version. Note that I am using GCP trial and the VM was set up exactly following your video tutorial. Appreciate the help.

Install kubeadm and kubectl
OK
Hit:1 http://us-central1.gce.archive.ubuntu.com/ubuntu xenial InRelease
Hit:3 http://us-central1.gce.archive.ubuntu.com/ubuntu xenial-updates InRelease
Hit:4 http://us-central1.gce.archive.ubuntu.com/ubuntu xenial-backports InRelease
Hit:5 http://security.ubuntu.com/ubuntu xenial-security InRelease
Get:2 https://packages.cloud.google.com/apt kubernetes-xenial InRelease [8,993 B]
Hit:6 http://archive.canonical.com/ubuntu xenial InRelease
Get:7 https://packages.cloud.google.com/apt kubernetes-xenial/main amd64 Packages [25.8 kB]
Fetched 34.8 kB in 0s (67.9 kB/s)
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
kubeadm : Depends: kubernetes-cni (= 0.6.0) but 0.7.5-00 is to be installed
kubelet : Depends: kubernetes-cni (= 0.6.0) but 0.7.5-00 is to be installed

Thanks,

Deb

Comments

  • debashishdebashish Posts: 5

    An issue at https://github.com/kubernetes/kubernetes/issues/75683 states that using 1.13.5 (or later) fixes this, do you recommend this?

  • debashishdebashish Posts: 5

    Please ignore, I should read other posts in the forum already. Using v 1.13.5 solved my issue.

  • chrispokornichrispokorni Posts: 268

    Hi Deb,
    Keep in mind there may be slight differences between v1.13.5 and v1.13.1 (the release tested for lab exercises).
    An easy fix for the v1.13.1 installation is to also install kubernetes-cni=0.6.0-00 when installing the 3 kube* components v1.13.1.

    Regards,
    -Chris

Sign In or Register to comment.