Welcome to the new Linux Foundation Forum!

Can't install kubeadm on Azure Ubuntu 16.04 (Lab 2.2)

vasyhinvasyhin Posts: 15
edited March 31 in LFD259 Class Forum

Getting the following error when running master.sh from Lab 2.2

The following packages have unmet dependencies:
 kubeadm : Depends: kubernetes-cni (= 0.6.0) but 0.7.5-00 is to be installed
 kubelet : Depends: kubernetes-cni (= 0.6.0) but 0.7.5-00 is to be installed

I have the following from apt-cache

[email protected]:~$ apt-cache policy kubernetes-cni
kubernetes-cni:
  Installed: (none)
  Candidate: 0.7.5-00
  Version table:
     0.7.5-00 500
        500 http://apt.kubernetes.io kubernetes-xenial/main amd64 Packages
     0.6.0-00 500
        500 http://apt.kubernetes.io kubernetes-xenial/main amd64 Packages
     0.5.1-00 500
        500 http://apt.kubernetes.io kubernetes-xenial/main amd64 Packages
     0.3.0.1-07a8a2-00 500
        500 http://apt.kubernetes.io kubernetes-xenial/main amd64 Packages

And I was able to workaround the issue by running
sudo apt-get install kubernetes-cni=0.6.0-00

But after that I was not able to run master.sh again as it contains apt-get upgrade (this will upgrade to kubernetes-cni 0.7.5-00 again).
So I called the rest of instructions from master.sh by hand.

How can we improve master.sh to automate the whole installation?

Comments

  • vasyhinvasyhin Posts: 15

    Similar issue with k8sSecond.sh as expected.
    Will workaround the same way.

  • chrispokornichrispokorni Posts: 302

    Hi @vasyhin,
    The installation scripts are simple shell scripts. You can change them in any way that works with your environment. You can add commands, specify software versions to be downloaded, or comment out updates if needed.
    Azure VMs are still a challenging environment for a vendor-neutral Kubernetes installation, but things are improving. There have been a few issues reported earlier in the forum, but have been worked out and solutions posted when found.
    Regards,
    -Chris

  • chrispokornichrispokorni Posts: 302

    Hi,
    With the release of a new Kubernetes version, lately, we noticed that prior versions are impacted in one way or another.
    Version 1.13.1 used for the labs was impacted by the kubernetes-cni package, where the current dependency is set to kubernetes-cni version 0.7.5 (the lates). Unfortunately, version 0.7.5 is not supported by our lab environment Kubernetes version 1.13.1, thus we need to manually install kubernetes-cni version 0.6.0 which is the supported version by Kubernetes 1.13.1.

    Before running the installation bash scripts for both Master and Second nodes, please edit the scripts to add an extra step right before the Kubernetes version 1.13.1 components installation step. Once edited, the script should look similar to:

    <...>
    sudo apt-get update
    sudo apt-get install -y kubernetes-cni=0.6.0-00
    sudo apt-get install -y kubeadm=1.13.1-00 kubelet=1.13.1-00 kubectl=1.13.1-00 
    <...>
    

    Regards,
    -Chris

  • I changed k8sMaster.sh to use 1.14.0-00 and it seemed to work for me.

    Not sure if this will come back to bite me later.

  • DavidSandersDavidSanders Posts: 5

    @Nico_de_Wet - thanks for your post, this worked for me - much appreciated. Thanks David :)

Sign In or Register to comment.