Welcome to the Linux Foundation Forum!

Lab 3.1



When I run the command on the main VM:

$ tcpdump -w /tmp/secondary-http.pcap -i enns33 port 80 and host secondary.example.com

I get the VMWare error in a dialogue box:
The virtual machine's operating system has attempted to enable promiscuous mode on adapter 'Ethernet1'. This is not allowed for security reasons.
Please go to the Web page "http://vmware.com/info?id=161" for help enabling promiscuous mode in the virtual machine.

But I don't understand what's wrong because I su'd to root to do the command and that should allow promiscuous mode. Am I missing something?

The .pcap file is made but nothing's been written to it, and no activity registered by tcpdump.


  • lee42x
    lee42x Posts: 380

    Hello, Quick question, "enns33" is that supposed to be "ens33", mine is "ens33".
    We can reduce the selection arguments and output directly to the screen with "sudo tcpdump -i ens33" , then wait for a few minutes, there may not be much traffic.
    The very first time I ran "sudo tcpdump -i ens33" I got a popup message like yours, oddly, it vanished on its own and started to show me the packets.

    The article mentioned is about using Linux for the "host" and "client" , please verify this is the case.


  • mo79uk
    mo79uk Posts: 42

    Thanks for the reply.

    Yes, typo, is ens33.

    I find the plain sudo tcpdump -i ens33 works fine, but when I do the command that outputs to the file I then get the error dialogue and no activity is shown or logged. And then afterwards the plain sudo tcpdump -i ens33 command doesn't work also.

    There's a few things I've worked out to try and will get back to you if I'm stumped. Many thanks.


Upcoming Training