Welcome to the new Linux Foundation Forum!

Packet loss extremely high on wifi (Nearly 100%) (BRM4331) (MBP 9,2)

I have a mid 2012 macbook pro running arch linux, everything has worked fine on it up until a few days ago. I have been using the b43-firmware-classic package as the network card is a BRM4331. A few days ago, I noticed the internet sometimes fluctuates anywhere from being slow to being so unstable that it is completely unusable. Running mtr on any address reveals very high packet loss. Most of the packet loss occurs on the very first step (_gateway). This packet loss ranges from about 5% to 90%. I've tried upgrading to b43-firmware (from b43-firwmare-classic), but it doesn't seem to change anything. I am using NetworkManager.

Any help or pointers would be appreciated as I really need a computer for school, thanks!

Note: This happens no matter what network I am on, and other devices on the same network do not experience the same problem

Note 2: Everything works totally fine on ethernet (0.00% packet loss)

Comments

  • Update: I'm pretty sure the B43 firmware is to blame. I was going to get the official drivers for this chip for linux, but apparently there are no official drivers for this chip on linux. Fantastic. What are my options from here? Are there other unofficial options?

  • Update 2: I installed wl even tho it's not supported by this wifi card. It struggles really really bad to connect to a network (have to try at very least 10 times to connect), but works great once connected! Any tips on getting it to connect on the first try like b43 did?

  • Update 3: according to this, https://bugs.archlinux.org/task/61119 it is a problem with wpa_supplicant 1.7 and I should downgrading to 1.6-12, however downgrading wpa_supplicant to 1:1.6-12 did not seem to solve the problem

Sign In or Register to comment.