Welcome to the new Linux Foundation Forum!

Vagrant timeout

Hello I am trying to launch the VM on Mac OS X High Sierra 10.13.6 with vagrant version 2.2.2 and virtualbox version 6.0 but I keep getting the following error even though i increased the boot timeout to 15 minutes.

~/fabric-fundamentals > vagrant up
Bringing machine 'default' up with 'virtualbox' provider...
==> default: Importing base box 'fabric-fundamentals'...
==> default: Matching MAC address for NAT networking...
==> default: Setting the name of the VM: fabric-fundamentals_default_1546978822486_40874
==> default: Clearing any previously set network interfaces...
==> default: Preparing network interfaces based on configuration...
    default: Adapter 1: nat
==> default: Forwarding ports...
    default: 3000 (guest) => 3000 (host) (adapter 1)
    default: 3333 (guest) => 3333 (host) (adapter 1)
    default: 8080 (guest) => 8080 (host) (adapter 1)
    default: 22 (guest) => 2222 (host) (adapter 1)
==> default: Running 'pre-boot' VM customizations...
==> default: Booting VM...
==> default: Waiting for machine to boot. This may take a few minutes...
    default: SSH address: 127.0.0.1:2222
    default: SSH username: vagrant
    default: SSH auth method: private key
Timed out while waiting for the machine to boot. This means that
Vagrant was unable to communicate with the guest machine within
the configured ("config.vm.boot_timeout" value) time period.

If you look above, you should be able to see the error(s) that
Vagrant had when attempting to connect to the machine. These errors
are usually good hints as to what may be wrong.

If you're using a custom box, make sure that networking is properly
working and you're able to connect to the machine. It is a common
problem that networking isn't setup properly in these boxes.
Verify that authentication configurations are also setup properly,
as well.

If the box appears to be booting properly, you may want to increase
the timeout ("config.vm.boot_timeout") value.

Comments

  • I was able to get it working by downgrading virtualbox version to 5.2.2

  • Hi All,

    Just wanted to drop a note that I was having the same issues and browsed a bunch of different resources trying to find what the issue was. I downgraded my virtualbox from 6.0.x to 5.2.2 as well and was able to boot my VM with no issues. I also had my Windows firewall disabled, but I don't think that played a role. This was on Windows 10.

  • I had same issue, downgrading virtualbox to 5.2 solved it for me. The course guidelines should be updated as this is not intuitive to understand by oneself.

Sign In or Register to comment.