Welcome to the new Linux Foundation Forum!

Cannot install devstack (lab 2.2), problem with barbican

I tried two times but still have problem.

This is the short version of the log

2019-01-05 14:09:50.827 | Obtaining file:///opt/stack/barbican
2019-01-05 14:09:51.681 | Complete output from command python setup.py egg_info:
2019-01-05 14:09:51.681 | /usr/local/lib/python2.7/dist-packages/setuptools/dist.py:42: DistDeprecationWarning: Do not call this function
2019-01-05 14:09:51.682 | warnings.warn("Do not call this function", DistDeprecationWarning)
2019-01-05 14:09:51.682 | ERROR:root:Error parsing
2019-01-05 14:09:51.682 | Traceback (most recent call last):
2019-01-05 14:09:51.682 | File "/usr/local/lib/python2.7/dist-packages/pbr/core.py", line 111, in pbr
2019-01-05 14:09:51.682 | attrs = util.cfg_to_args(path, dist.script_args)
2019-01-05 14:09:51.682 | File "/usr/local/lib/python2.7/dist-packages/pbr/util.py", line 267, in cfg_to_args
2019-01-05 14:09:51.682 | wrap_commands(kwargs)
2019-01-05 14:09:51.682 | File "/usr/local/lib/python2.7/dist-packages/pbr/util.py", line 569, in wrap_commands
2019-01-05 14:09:51.682 | cmdclass = ep.resolve()
2019-01-05 14:09:51.682 | File "/usr/local/lib/python2.7/dist-packages/pkg_resources/init.py", line 2352, in resolve
2019-01-05 14:09:51.682 | module = import(self.module_name, fromlist=['name'], level=0)
2019-01-05 14:09:51.682 | File "/usr/local/lib/python2.7/dist-packages/flake8/main.py", line 6, in
2019-01-05 14:09:51.682 | import pep8
2019-01-05 14:09:51.682 | ImportError: No module named pep8
2019-01-05 14:09:51.682 | error in setup command: Error parsing /opt/stack/barbican/setup.cfg: ImportError: No module named pep8
2019-01-05 14:09:51.682 |
2019-01-05 14:09:51.682 | ----------------------------------------
2019-01-05 14:09:51.682 | Command "python setup.py egg_info" failed with error code 1 in /opt/stack/barbican/
2019-01-05 14:09:51.814 | You are using pip version 9.0.3, however version 18.1 is available.
2019-01-05 14:09:51.815 | You should consider upgrading via the 'pip install --upgrade pip' command.

Attached zip file is the full version of the installation log.

Comments

Sign In or Register to comment.