Welcome to the Linux Foundation Forum!

CentOS 7 vm no bootable device


I am trying to import the latest CentOS7 image into KVM. However, when I start it, I get No bootable device. I've looked at the configuration for boot options, and it's set for VirtIO Disk 1. I have tried converting the image to a qcow, but that didn't help. How do I get the image to boot in KVM?


  • davidpaige

    Followup: It seems to boot without any issue using Boxes. I can use it that way. It would still be nice to know what I am doing wrong using KVM.

  • coop
    coop Posts: 915

    Sorry, we haven't tested with the KVM for a while as it these VM's are almost always used with either vmware or virtualbox. Hopefully we can figure out the problem. (I have verified similar behaviour) Kind of weird....I am not surprised the vmdk file doesn't work in KVM since it would be read-only, but the qcow2 should work.

  • lee42x
    lee42x Posts: 380

    I just tried KVM & CentOS7. The disk type needs to be changed to "IDE" in KVM, under "advanced options". The VMDK format image worked fine although there suggestions that "qcow2" is faster.


Upcoming Training