Welcome to the new Linux Foundation Forum!

Lab 5.5 - ssh prompts for password to install keys

I'm working on lab 5.5 with CentOS7. When I run ssh-copy-id localhost, my system tries to log in with the keys but then prompts me for a password.

I have already set /etc/ssh/sshd_config -> PermitRootLogin to without-password.

Comments

  • lee42xlee42x Posts: 87

    Hi, Sorry to hear there is a challenge. You are having an issue with section 5.5 parallel ssh ? In step 5.5.2 the "ssh-copy-id localhost", is only required if not already done in the previous steps.

  • Thanks lee42x. I managed to resolve the issue. I deleted the root's /.ssh directory and that appears to have fixed it. I suspect it may have been the root's personal ssh config. Do personal ssh configs override the sshd_config? I think they might.

  • lee42xlee42x Posts: 87

    Yes, the $HOME/.ssh/config configuration is the last to be applied so its values will be applied. Also worth mentioning, if you have the same parameter specified twice in a single ssh config file, the last entry will be true..

Sign In or Register to comment.