Welcome to the new Linux Foundation Forum!

Lab 17.3

mo79ukmo79uk Posts: 26
edited September 12 in LFS201 Class Forum

Near the end of instruction 7 when I try to mount the vfat partition I get the error (on Ubuntu):

/home/student/mnt3: wrong fs type, bad option, bad superblock on /dev/loop9p3, missing codepage or helper program, or other error.

I've tried adding -t vfat to the middle of

$ sudo mount /dev/loop9p3 mnt3 (making it sudo mount -t vfat /dev/loop9p3 mnt3)

but I get the same error. Any suggestions?

Dmesg reports: IO charset iso8859-1 not found

Comments

  • coopcoop Posts: 249

    There are a couple of possiblities here:
    1) did the mkfs.vfat command report no errors? Obviously if the filesystem was not created it can't be mounted properly
    2) Does your kernel have vfat filesytem support?
    You could look at /proc/filesystems, to see if "vfat" is in there, but that is not authoritative. If vfat was compiled as a module it will be loaded only on demand when you mount. BTW, the -t vfat option is kind of a no-op as the system will detect the filesystem type if it can anyway) I think we removed it in the next version of LFS201.
    So you need to see what kernel you are running -- is it the distribution kernel from Ubuntu? That probably has vfat compiled.
    You could do something like:

    c7:/tmp>uname -r
    4.18.7
    c7:/tmp>grep VFAT /boot/config-4.18.7
    CONFIG_VFAT_FS=m
    

    or
    c7:/tmp>grep VFAT /boot/config-$(uname -r)
    CONFIG_VFAT_FS=m

    to be even slimpler

  • mo79ukmo79uk Posts: 26
    edited September 12

    Those commands give me:

    4.18.0
    CONFIG_VFAT_FS=y

    I'm using the pre-built Ubuntu VM image. There were no errors about making the partitions (I see them all when I do ls -l /dev/loop9*). On making the VFAT partition all it printed was: mkfs.fat 4.1 (2017-01-24)

  • coopcoop Posts: 249

    what kernel are you using. I won't guarantee a custom built kernel has vfat built in. If you are using a LF VM, you should use the Ubuntu kernel that is shipped stock. Do uname -r to see

  • mo79ukmo79uk Posts: 26

    4.18.0.

    I just tried doing it all in Cent OS and I've not had problems there. Would be interesting to know why but it's not critical.

  • coopcoop Posts: 249

    I'm sorry but you did not report on whether you check the kernel configuration option any further discussion would require that

  • mo79ukmo79uk Posts: 26
    edited September 12

    Is it not 4.18.0? That's what uname -r gave on Ubuntu.

    catting /proc/filesystems showed vfat listed. And grepping the config gave: CONFIG_VFAT_FS=y

  • coopcoop Posts: 249

    No idea when. But is this on ububtu

  • mo79ukmo79uk Posts: 26

    Yes, specifically the pre-built VM. Maybe there's no issue with a manual install.

  • coopcoop Posts: 249

    sorry you are not understanding. All our pre-built VM's come with two kernels installed, the stock distro kernel and at the present moment, 4.18 as the latest kernel.org vanilla kernel, custom compiled. I'm pretty sure our custom kernels come with VFAT installed as built in. You never made clear what kernel you were running. On my system Ubuntu 18.04 is running a config-4.15 kernel with VFAT built is as is the custom kernel:

    [email protected]:/boot$ grep VFAT config*
    config-4.15.0-30-generic:CONFIG_VFAT_FS=y
    config-4.18.0:CONFIG_VFAT_FS=y
    [email protected]:/boot$

    so it should not matter. But please be clear in what you are saying when you post to cut the size of the threads. I don't know enough to know why you had problems. Let me know if you figure it out

  • mo79ukmo79uk Posts: 26

    4.18.0 (config-4.18.0) is what I get in this Ubuntu 18.04 VM. That's what I see in uname -r and then also grepping vfat, or catting /proc/version, and it's the default kernel version selected in GRUB.

    I didn't try the other listed kernels (4.15.0-34 and 4.15.0-33 as well as 4.4.0-131), but maybe they would've resolved the problem. Hopefully this thread will assist others who are stumped. I saw VFAT listed as a supported file system so I'm confused - but it was all fine on CentOS.

    Apologies for expanding this thread too much.

  • coopcoop Posts: 249

    no apology needed :)

  • jengeljengel Posts: 41

    Ran into this previously and and the article below sent me in the right direction. If not that then simply your image may be kaput. Is the image you mount on CentOS the same one you cannot mount Ubuntu?

    https://askubuntu.com/questions/372445/fat-fs-io-charset-iso8859-1-not-found-error-while-mounting-fat-drives

  • mo79ukmo79uk Posts: 26

    Yes, it's probably the default kernel in that VM (I've proceeded to further modules so didn't retest) or maybe the VM image itself. My CentOS was a manually made VM. I've also got openSUSE (manually made too) and I just selected Ubuntu at random for this lab first.

Sign In or Register to comment.