Welcome to the new Linux Foundation Forum!

How do I download and install libcurl3 Kali?

schismschism Posts: 11

Hi, I'm trying to install Powershell on Kali. After doing a lot, I get to the step where I enter "apt -y install powershell." I get the error "Depends:librcurl3 but it is not installable." So how do I install libcurl3? I tried apt-get install libcurl3 and it gives me the error "Package libcurl3 has no installation candidate." It says I have libcurl4 etc... I downloaded libcurl3_7.38.0.deb, and ran dpkg libcurl3 etc... but it says I need multiarch support. I downloaded the amd64 version of lubcurl3. This is probably an easy question.. So can anyone help me install libcurl3 so I can continue with Powershell? Thanks

Comments

  • schismschism Posts: 11

    Hi, thanks for your fast reply. I'm actually using that exact same link and instructions to install Powershell. Everything is successful till the "apt -y install powershell." That's where I get stuck. Do I need to install libcurl3? Please reply. Thanks

  • schismschism Posts: 11

    Me again...I enabled multiarch, downloaded a new libcurl3, and run dpkg. Now I get the error about libcurl3 conflicts with libcurl4. conflicting packages and doesn't install. Should I remove libcurl4? Can I have them both? I'm attaching a screenshot. Please reply. Thanks

  • schismschism Posts: 11

    I'm back. I got it to work but have another question. I ran apt-get autoremove libcurl4 and it deleted a lot of stuff (hopefully that won't be a problem?) Then I ran apt-get install lilbcurl3 and it finished. Then I ran "apt -y install powershell" and it worked! Now I type pwsh like your link and it opens fine. My questions is should I re install libcurl4? It removed a lot when I ran it and I don't want any problems with other things.

  • schismschism Posts: 11

    Hi, libcurl3 was automatically removed and libcurl4 was updated. Now pwsh doesn't work. Is there any workaround for this? I was using the instructions from Kali's website.

Sign In or Register to comment.