Welcome to the new Linux Foundation Forum!

18.7.b Checking and fixing Filesystems II

jengeljengel Posts: 41
edited August 13 in LFS201 Class Forum

I was checking into following statement, which did not make sense and I was wondering if it was meant to be "sudo fsck /dev/sda10" i.e. without the "-t ext4".


If the filesystem is of a type understood by the operating system, you can almost always just do: $ sudo fsck -t ext4 /dev/sda10 and the system will figure out the type by examining the first few bytes on the partition.

So I checked man fsck and now even more confused. To double check I also checked the source code for fsck and confirmed it align to what is stated in man.



from man:



 


-t fslist Specifies the type(s) of filesystem to be checked. When the -A flag is specified, only filesystems that match fslist are checked. The fslist parameter is a comma-separated list of filesystems and options specifiers. All of the filesystems in this comma-separated list may be pre‐fixed by a negation operator 'no' or '!', which requests that only those filesystems not listed in fslist will be checked. If none of the filesystems in fslist is prefixed by a negation operator, then only those listed filesystems will be checked. < irrelevant parts snipped out> Normally, the filesystem type is deduced by searching for filesys in the /etc/fstab file and using the corresponding entry. If the type cannot be deduced, and there is only a single filesystem given as an argument to the -t option, fsck will use the specified filesystem type. If this type is not available, then the default filesystem type (currently ext2) is used.

From source code:


/* * Run the fsck program on a particular device * * If the type is specified using -t, and it isn't prefixed with "no" * (as in "noext2") and only one filesystem type is specified, then * use that type regardless of what is specified in /etc/fstab. * * If the type isn't specified by the user, then use either the type * specified in /etc/fstab, or DEFAULT_FSTYPE. */

 

From this it would seem fsck does not check the partition but use fstab, or "-t", or default to ext2.



Can anyone confirm this or point me in the direction where I can find documentation discussing the "examining the first few bytes on the partition."?



Then, the original question I thought I was going to find the answer for: Were the "-t ext4" a typo in slide as referenced above?

 

Comments

  • coopcoop Posts: 221
    edited August 13

    It is not an error.  From the man page for fsck, it explains the "-t" option as:

     -t fslist

                  Specifies the type(s) of filesystem to be checked.  When the  -A

                  flag  is  specified,  only  filesystems  that  match  fslist are

                  checked.  .....

    There is no typo.  fsck certainly does not look at /etc/fstab (the filesystem can easily be unknown there).  Normally I would never use the -t option except in an error problem.  For example, you culd have a certain filesystem type understood by the system but have no fsck progam associated it, say you are missing fsck.btrfs.

  • jengeljengel Posts: 41
    edited August 16

    Thank you for clarifying. Based on your feedback I experimented a bit and found that if one is working on the command line specifying -t option indeed more than redundant - because it check for itself anyway.

    For example I deliberately created a FAT filesystem, made sure not to include it in the fstab and ran fschk with "-t ext2" on it. Without any complaints it simply ran the correct check (fsck.fat).
    Running the relevant filesystem checker (fsck.ext2) directly do not give you this safeguard and will happily destroy the filesystem trying to fix it.
    fstab I guess therefore is only relevant during boot checks?

    This is not well documented, I think, and I probably would have not known this if it did not come up in this course (+1 for the course :) )

    Is this a matter of the documentation not being quite up to date or is there some other sense to those statements that confused me? I would have thought the fact it checked anyway could have been mentioned somewhere.

  • coopcoop Posts: 221

    I don't believe any fsck will destroy something it does not recognize, it will just say the superblock is not there etc. No fsck program makes changes unless you run it in "force" mode without requesting permission.
    /etc/fstab is consulted:
    1) at boot to decide what should be mounted at system start
    2) later if you do a command like mount -a, or umount -a , or to mount a filesystem that has noauto specified so the system does not fail when booting and cannot mount it

  • jengeljengel Posts: 41

    The curious person I am I tried it. And it did destroy it.
    Yes, it tried to do plenty of superblock fixes, had to stick my finger to the "y" key for a while giving those permissions. After this I tried to mount it was not possible.

    On fstab, which process check/use the field we learn about in Mounting Filesystems (18.13.b) "fsck pass number (or 0, meaning do not check state at boot.". I thought it was fsck itself.

  • dr4Kedr4Ke Posts: 8

    To experiment a bit with this, I created 5 partitions, from scratch, with each a different FS type: ext2, ext3, vfat, btrfs and xfs.
    Then I tried to check these with fsck /dev/vgtest/lv${FS} and it detected the right FS type indeed. So the man page is probably outdated, as it tells about /etc/fstab but not about guessing the type from the actual FS.
    As @jengel said, it even ignores a wrong type entered in the command line with -t, and use the right checker.

    Out of curiousity, I added a new volume, with no FS but random data instead. Then issued fsck /dev/vgtest/lvrandom. It didn't recognized the FS type, and tried the default one, e2fsck, as stated in the man page. Obviously it didn't find any superblock.

    So I would remove the -t ext4 from the third command in this page of the course. It's disturbing as the sentence says that fsck is getting the right FS type itself, but we put a type in the command line anyway (even a wrong one).

  • coopcoop Posts: 221

    This was already fixed quite some time ago in the working copy for next release. I don't know when the discussion was but I remember it and it was already done

Sign In or Register to comment.