Welcome to the new Linux Foundation Forum!

Trouble accessing Rancher container from Windows machine

jnavalijnavali Posts: 12
edited August 2018 in LFS263 Class Forum

Hi,

I am following the Lab 1 instructions to setup ONAP.

Step 13: I ran the following on a gcloud shell


gcloud compute ssh --zone "northamerica-northeast1-a" "onap-test-01" -- -N -D localhost:5000

Step 14: setup proxy setting as described in the document

Everything went well upto step 14 on page 11 - setting up Proxy on Firefox.

I am not able to access the Rancher UI from my Windows 10 laptop by accessing at 

http://192.168.122.231:8880/

The connection times out.

"The connection has timed out

The server at 192.168.122.231 is taking too long to respond."

Is there any more config needed on a Windows 10 machine to setup a SOCK5 proxy for this?

Any alternate approach to getting to this UI?

[

I tried ssh local forwarding by setting up a tunnel to 192.168.122.231:8880 with the following but it did not work:

gcloud compute ssh --zone "northamerica-northeast1-a" "onap-test-01" -- -N -L 5000:192.168.122

.231:8880 -vvv

]

Rancher server container seems to be up:

[email protected]:~$ docker ps -a

CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES ac4e4eaaedaa rancher/server:v1.6.10 "/usr/bin/entry /usr/" 3 hours ago Up 3 hours 3306/tcp, 0.0.0.0:8880->8080/tcp rancher_server

 

Appreciate any help resolving this.

 

Thanks

Jay

Comments

  • akapadiaakapadia Posts: 20
    edited August 2018

    Hi Jay,

    The SOCKS5 connection needs to be made from your laptop and not gcloud shell.

    So you can follow the documentation by running the appropriate gcloud command on your Windows machine, or you can use PuTTY as well again on your laptop.

    Let us know if this works. Thanks.

  • srupanaguntasrupanagunta Posts: 4
    edited August 2018

    One additional note: In case you already tried gcloud command from your Windows laptop, the usage of this command may be little different from what we documented (which is on Linux). You could try using PuTTY client (which is documented in the Lab manual). 

    Hope this helps. 

  • jnavalijnavali Posts: 12

    Thanks for the response.

    There seems to be no mention of PuTTY in lab manual?

  • jnavalijnavali Posts: 12

    I was able to get around this issue after uploading a ssh key into the VM instance on GCE.
    I could then run ssh with the -N -D options to start the SOCKS proxy on the windows machine.

  • akapadiaakapadia Posts: 20

    Great, in the meantime I also send PuTTY instructions. We will add those to the document as well.

Sign In or Register to comment.