Welcome to the Linux Foundation Forum!

Cannot Open 32GB Flash Drive


I am running Linux Mint 16 Cinammon on my Dell Inspiron 580s Desktop PC. Recently, I obviously made a big mistake by downloading both Linux Bodhi 64-bit version and Puppy Linux on to the same drive. What I mean is that when I had to tried to open and view critical files I had backed up on it on Windows PCs, I had been getting more and more error messages about drive formatting errors. Even worse, it was showing the flash drive as having NO folders/files on it, and then showing all the files I had saved to it when I still went ahead and double-clicked to open it!?

Tonight I tried again to open the USB drive in Linux Mint 16, only to see the exact following lines in an error message window:

Unable to mount Bodhi Linux

"Error mounting /dev/sdf2 at /media/craig/Bodhi Linux: Command-line `mount -t "iso9660" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,iocharset=utf8,mode=0400,dmode=0500" "/dev/sdf2" "/media/craig/Bodhi Linux"' exited with non-zero exit status 32: mount: block device /dev/sdf2 is write-protected, mounting read-only

mount: wrong fs type, bad option, bad superblock on /dev/sdf2,

missing codepage or helper program, or other error

In some cases useful info is found in syslog - try

dmesg | tail or so"

I am a complete newbie, so I can't quite decode all of this message, and have already tried getting any answer from the Linux Mint forum.

When I enter "mount -t "iso9660" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,iocharset=utf8,mode=0400,dmode=0500" into a Terminal window, all I get is > on the next line. What?? What am I supposed to enter as a command or commads? Even entering "dmesg | tail or so" totally lost me with this puzzling response:

tail: cannot open ‘or’ for reading: No such file or directory

At this point, all I want to do is be able to save the non-Linux critical folders and files to my SATA hdd and then reformat the drive to what file extension? If I must just go ahead and reformat the drive and lose everything on it, so be it. Another very costly and painful lesson hopefully learned. Oh, and one final question. Why don't any of the Topic Icon(s) except maybe the "Question" one display what they are? Not helpful at all.


Upcoming Training