Welcome to the new Linux Foundation Forum!

Lab 6.1: NetworkPolicies not working

mrmcmuffinzmrmcmuffinz Posts: 9
edited May 2018 in LFD259 Class Forum
HI, I tried setting up the Ingress/Egress policies but I only got the first example to work everything else just does not seem to behave like how it is presented in the lab. In fact I think I found an occurrence of copy-paste on page 12 very end. Below is what I mean:


[[email protected] ~]$ curl http://35.184.219.5:32215
curl: (7) Failed to connect to 35.184.219.5 port 32000: Connection timed
out

How can you be curling 32215 but the message says your tried 32000?

Not only that I found it hard to do some of the NetworkPolicy yamls because they were split up between 2 pages so I just couldn't figure out the indentation. I ended up going to the kubernetes.io website and looking at the NetworkPolicies there. I would appreciate some guidance on why the network policies aren't working.

Comments

  • chrispokornichrispokorni Posts: 177

    Hi, thanks for pointing out the port number typo on page 12. Good catch! It will be corrected in a future course update. Beginning from the top of page 11 and on, port 32000 should be used to complete this lab.

    I know how frustrating it is when your own results are different from the ones presented in the lab manual. In order to assist you with them, can you provide some outputs, or any details which would help with troubleshooting to identify the issue? 

    The labs have been beta tested, and all commands and outputs have been reproduced as presented in the lab manual. For consistency however, every time they were completed on Google Compute Engines inside VPCs.

    From my own experience, yaml files tend to be the root-cause of many issues, and getting the indentation right would most likely fix any errors or discrepancies encountered. Since the same lab may go over the same yaml file several times, I found it useful to just scroll thru the lab pages and try to match similar parts of the file in order to get the indentation right.

    Regards, 

    -Chris

Sign In or Register to comment.