Welcome to the new Linux Foundation Forum!

vCPU limit in Google Cloud

greg1wgreg1w Posts: 2
edited May 2018 in LFS263 Class Forum

Lab 1 requires a VM with 40 vCPUs. However, the limit in the Google Cloud US-Central1 zone is 24 vCPUs. I've requested an upgrade from Google cloud but the request was denied.  I'm attempting the lab with a 24 vCPU VM but not sure if/when it'll crap out.

Anyone have any luck with this or other suggestions?

 

Comments

  • akapadiaakapadia Posts: 20
    edited May 2018

    If you try with less than 40 vCPUs, you will most likely get kernel errors that may freeze the VM. If you want give it a try, perhaps if you are lucky OOM will go through without any errors. Separately, have you enabled billing? You should be able to bump up your quota if billing is enabled. Google charges you a little bit upfront to make sure things are OK, but then they typically approve a quota increase. 

  • greg1wgreg1w Posts: 2

    Yes, billing is enabled. Support gave a strange response about not being able to increase quota due to an error but gave no details on that error. I'm retrying the quota increase request because I don't want to waste hrs trying to install on a config that's probably going to error out.

  • EDDROPI135EDDROPI135 Posts: 7
    edited August 2018

    I am facing the same problem that upon trying to create the VM with 40 vCPUs i get an error message back saying I am allowed max of 8 vCPUs in region us-central1. Any idea how to overcome this limitation?

  • akapadiaakapadia Posts: 20

    For me, once Billing was enabled, they allowed 40 vCPUs. Don't completely remember, I might have had to request a quota increase, but that was granted very quickly as well. Why don't you try chatting with their billing support https://support.google.com/cloud/contact/cloud_platform_billing?

  • The limitation vCPU limit=8 in region us-central1 was due to the fact that my google cloud account was still "free trail". Solution: upgrade your account by going to IAM->quota (there you will find the "upgrade account" button on the right side).

    After successfully upgrading the account you still face the same issue this time the vCPU limit=24. Now you have to increase the vCPU quota of zone us-centra1 from 24->40, this is done via IAM->quota (filter on Location = us-central1, then filter on Metric = CPUs, select your instance, click on "edit quota" and enter the new value "40" in the first text box). You will get an e-mail and the quota increase was done in my case fairly fast (within 4 hours). After this, the command to create the instance worked fine!

Sign In or Register to comment.