Welcome to the Linux Foundation Forum!

My Experience with Linux Mint 15 MATE DE-Problems

Otaku Posts: 1
edited October 2013 in Getting Started with Linux

Hey fellow Linux-mates

I wanted to share some experiences that I had with my first Linux OS install.

I would like to start off with saying that I am not even close to being a novice user of Linux - I am still very new to the OS. I may be using terms that would be applicable towards Windows, and that I will try my best to use Linux terms.

This is my first post in the Linux Forums, I have not asked for any help, but instead I researched all the Ubuntu and Linux forums for all the problems I ran into - and there were so many problems.

To start - I first installed Ubuntu, and had so many problems - My wireless and wired drivers were not installed beforehand, and I could not use internet at ALL. Frustrated, I researched some options - and found that I would want to install Ubuntu Ultimate with the whole package (ndiswrapper included) or a Linux DE. I opted for Linux Mint 15 with the MATE desktop since it was the most stable so far. Upon my first install - it worked wonderfully. I decided to follow all the newbie reccomendations of messing with my OS - to learn my way around. I eventually broke it - and am still struggling to get it back to normal.

First, I tried installing and configuring SAMBA - I had issues trying to connect to Windows FileShare. After three days of fumbling, frustration, learning, and configuring, (with these links; http://ubuntuforums.org/showthread.php?t=202605&highlight=file+sharing and http://ubuntuforums.org/showthread.php?t=1169149) I found out that Windows will not "see" my Linux box unless it was within the IP range that the Windows wireless driver was connected to. For some reason, the (open source?) bcmwl kernel source driver for my wireless that I installed via driver manager sets me to a completely different IP range, so after researching, I followed a forum's reccomendation (http://ubuntuforums.org/showthread.php?t=2169844&highlight=4727) and purged the bcmwl kernel. It worked, and put me within the IP address range I needed, and my Windows "saw" my system! However, after a reboot, my wireless quit, stopped working, and I had no wireless internet at all. I hooked up to an ethernet cable, and tried reinstalling the bcmw kernel. I had so much trouble with it - for some reason it made my system so unstable.

What did I do afterwards?

Well - I grabbed my liveCD (USB) and attempted to "fix" what I broke - and can I say I broke it good? I'll say it - I broke my stable OS real good.

Upon booting the LiveCD with the same OS I originally installed and tried fixing (NO FORMAT!) via instructions on how to fix a linux system on these wonderful forums. I was then told that my hard drive (which I pulled from a PS3 and reformatted to NTFS, then to EXT4 VIA LIVECD) was set to "RAID" format and that the installation/fixing might fail. I rebooted, got into BIOS, and looked around - saw nothing about RAID format at all. In addition, it said that my disk drive was full - which is impossible, I have a 40GB drive.

Well, super.

I basically said, screw the LiveCD, and rebooted to attempt changes in the terminal.

I saw in GRUB that I could use a previous version of Linux Mint 15 - good! I logged into that, and all wireless was working.

Guess what I did next; I looked up my NetworkManager because I was having problems with a serious bug with it - it would freeze upon opening from "Control Panel" and attempted to purge it (Not the best idea) and install WICD. Well that install failed (was missing a plugin even though I installed the package. I searced package manager (default install) for the addon, and didn't see it.)

Frustrated, I uninstalled it and reinstalled network manager, via su - .

I think it is working I have internet now- but it is slower and in addition, I have trouble accessing linux mint forums from google search (server times out).

Also, NetworkManager still freezes and never fully opens when accessed from Control Panel.

All this has discouraged me from wanting to continue messing with my system, which is disappointing - because I loved managing Linux.

I honestly feel that this laptop in particular may be to blame with its outdated graphics card (ATI Raedon 4xxx series), and outdated everything else. I have a gaming desktop computer with Windows 7 on it that has had NO problems (except one when I had smart caching enabled and RAID had so many problems, so I threw out smart caching and used my ssd as an external storage drive)and had a wonderful BIOS interface.

If anyone wants to work with me to figure out how badly I messed it up - and how I could figure out how to get it back to mint working condition - I would be extremely grateful if I were to avoid a complete clean reinstall seeing as the liveCD is not working. (I used unetbootin to create it)

Props to everyone for helping me out thus far - all your forum threads have been very useful and concise. Much appreciated!


Upcoming Training