Welcome to the Linux Foundation Forum!

microphone not working in Skype..

stellla Posts: 28


After installing the new distribution 12.04, everything works fine, except for the microphone in Skype. The video and speakers work ok, though.

Everything works good on Google Talk. Audacity shows that the internal microphone works on the laptop. I have been playing around with alsa mixer and pulse audio control but still can't do anything. I tried uninstalling skype and installing the newest version... which isn't for 12.04 specifically.

Is there a specific command that I could use in a terminal, or should I just ditch Skype and use Google Talk?

Any advice would be usefull, since I can't understand why it worked in previous distributions. Maybe it is a bug in skype.


  • Goineasy9
    Goineasy9 Posts: 1,114
    Sorry for the delay in response. I always had problems setting up skype, so I feel your pain. It's also probably the reason I don't use it anymore. That said, the only way I was able to get it set up, the last time I did it was to fiddle with the settings in PulseAudio.

    My install was using Fedora, but, I think Ubuntu uses it also. You might try installing pavucontrol and paman and see if one of the settings could be changed to point to Skype.

    Sorry I couldn't be more help, but I don't have Skype installed to look at it.
  • stellla
    stellla Posts: 28
    I tried all that, and no change. I can't help thinking that it's the test call app. that is the problem and that it might actually work. It happened before. I even ran commands in a terminal to test the microphone and it showed that it worked.
  • Just a note.... my husband did something wrong and the whole system crashed and I had to reinstall it. Ubuntu 12.04. The nice thing is that once I got everything as it was, and installed Skype.... I tested it and everything worked... I don't know whether the problem was theirs or the OS, but whatever- a complete reinstall worked. Just be sure to save everything important.. on Ubuntu One or some other storage device.
    Hope this helps. Someone once said that if all else fails, just start over from the beginning.
  • Goineasy9
    Goineasy9 Posts: 1,114
    Thanks for the update. I've also noticed that reinstalling sometimes solves some of those irritating problems.


Upcoming Training